By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,266 Members | 1,297 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,266 IT Pros & Developers. It's quick & easy.

Sql Server does not exist or access denied issue again

P: n/a
I know this has come up frequently but I can't seem to put my finger on
the precise problem as it applies to me. I have a workgroup with a 2003
box with Sql server on it. Also, on this, I have an XP pro machine. So
the xp pro machine is running IIS. When I try and open a connection to
the Sql Server I get the Sql Server does not exist etc.

I am wondering what I need to do to correct this exactly. Because it is
on a workgroup and not a domain how do I solve the problem. Do I need
to have an id on the xp machine that is the same as one of the server,
I tried this but it doesn't seem to work for me.

There is plenty of info out there for domains but not workgroups. Any
ideas??

Thanks

Eamonn

Jul 23 '05 #1
Share this Question
Share on Google+
7 Replies


P: n/a

"Jenbo" <ej***@allstate.com> wrote in message
news:11**********************@f14g2000cwb.googlegr oups.com...
I know this has come up frequently but I can't seem to put my finger on
the precise problem as it applies to me. I have a workgroup with a 2003
box with Sql server on it. Also, on this, I have an XP pro machine. So
the xp pro machine is running IIS. When I try and open a connection to
the Sql Server I get the Sql Server does not exist etc.

I am wondering what I need to do to correct this exactly. Because it is
on a workgroup and not a domain how do I solve the problem. Do I need
to have an id on the xp machine that is the same as one of the server,
I tried this but it doesn't seem to work for me.

There is plenty of info out there for domains but not workgroups. Any
ideas??

Thanks

Eamonn


http://support.microsoft.com/default...b;en-us;328306

If this doesn't help, then you should post some more information - which
version and edition of MSSQL do you have, which authentication mode are you
using, how are you testing the connection etc.

Simon
Jul 23 '05 #2

P: n/a
I have looked at this article a lot and it does not have any specific
info on workgroups, just domains. I am using SQL Server Enterprise I
think, authenication is mixed mode. The problem seems to be that the
user of the client machine cannot access the SQL server. Do I need to
do something like create a user on the client called test with pwd and
then create the same user on the server machine, and create this in SQL
Server???

This is a workgroup I am dealing with not a domain so I am wondering if
this would work.

Simon Hayes wrote:
"Jenbo" <ej***@allstate.com> wrote in message
news:11**********************@f14g2000cwb.googlegr oups.com...
I know this has come up frequently but I can't seem to put my finger on the precise problem as it applies to me. I have a workgroup with a 2003 box with Sql server on it. Also, on this, I have an XP pro machine. So the xp pro machine is running IIS. When I try and open a connection to the Sql Server I get the Sql Server does not exist etc.

I am wondering what I need to do to correct this exactly. Because it is on a workgroup and not a domain how do I solve the problem. Do I need to have an id on the xp machine that is the same as one of the server, I tried this but it doesn't seem to work for me.

There is plenty of info out there for domains but not workgroups. Any ideas??

Thanks

Eamonn

http://support.microsoft.com/default...b;en-us;328306

If this doesn't help, then you should post some more information -

which version and edition of MSSQL do you have, which authentication mode are you using, how are you testing the connection etc.

Simon


Jul 23 '05 #3

P: n/a
Try adding the hostname(xp machine) to the LMHost file on win2003. And
then try adding it to sql client configuration.

It worked for me.

Jul 23 '05 #4

P: n/a

"Jenbo" <ej***@allstate.com> wrote in message
news:11*********************@f14g2000cwb.googlegro ups.com...
I have looked at this article a lot and it does not have any specific
info on workgroups, just domains. I am using SQL Server Enterprise I
think, authenication is mixed mode. The problem seems to be that the
user of the client machine cannot access the SQL server. Do I need to
do something like create a user on the client called test with pwd and
then create the same user on the server machine, and create this in SQL
Server???

This is a workgroup I am dealing with not a domain so I am wondering if
this would work.


<snip>

If you're using mixed mode, then the first thing to try would be connecting
with a SQL login which you know works fine when you're logged on to the
server:

osql -S MyServer -U sa -P xxxx

If that doesn't work, then you probably have some basic connectivity issue,
so you could look at name resolution, protocol configuration and so on. If
it does work, but a trusted connection doesn't, then you probably have an
issue related to workgroup security. As far as I know, if you have local
user accounts on the client and server with the same name and same password,
then you should be able to connect to the server. However, it's possible
that Server 2003 is setup somehow to disallow such connections by default -
you can test with something basic like connecting to a share on the server.
If that doesn't work, then you'll have to investigate workgroup security,
which is probably something to take up in a Windows security group.

Personally, I would consider setting up a domain - if you have the resources
to implement Enterprise Edition on Server 2003, then presumably you have the
resources to operate a domain, although of course I don't know your
situation, so you may well have a good reason for going with a workgroup.

Simon

Jul 23 '05 #5

P: n/a
I was having this exact same problem yesterday and foud out the fix
just 30 minutes ago. I am also operating in a Workgroup and like you
could not find any solutions. I hope this helps...

On the server running MSSQLServer,
Open the network connection properties for you NIC.
Be sure you only have the following installed:
Client for MS Networks
File and Printer Sharing
TCP/IP

I originally had these additional components installed:
AppleTalk
Client Network Monitor

I removed both from Add/Remove Windows Components and network
connections at the same time, so not sure which one caused the
conflict.

Good Luck

Jul 23 '05 #6

P: n/a
I have a related question: when i installed sql server, i chose windows
auth. instead of mixed mode. Although a second pc can see a sql
instance from the first pc, i cannot log-in using a sql login. How do i
change to mixed mode?

Jul 23 '05 #7

P: n/a
chrispycrunch (ch***********@gmail.com) writes:
I have a related question: when i installed sql server, i chose windows
auth. instead of mixed mode. Although a second pc can see a sql
instance from the first pc, i cannot log-in using a sql login. How do i
change to mixed mode?


You do this from Enterprise Manager. If memory servers, you right-
click the server, choose properites, and then go the Security tab.
--
Erland Sommarskog, SQL Server MVP, es****@sommarskog.se

Books Online for SQL Server SP3 at
http://www.microsoft.com/sql/techinf...2000/books.asp
Jul 23 '05 #8

This discussion thread is closed

Replies have been disabled for this discussion.