By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,419 Members | 1,636 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,419 IT Pros & Developers. It's quick & easy.

Starting the SQL Service through Enterprise Manager

P: n/a
Folks,

We're implementing a software based mirroring solution. This solution
requires that the SQL Server service on the target server be stopped
while data is being replicated from the source server.

One problem we encountered while testing was that the SQL Server
Service on the target server was inadvertantly started when users
selected that server in Enterprise Manager. Is there any way to keep
the service from starting through Enterprise Manager?

Thanks

Jul 23 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
I would suggest to go into Services on that server and change the SQL Server service from Automatic to Manual. This then needs human intervention to turn on the Service.

Jeff

--
Message posted via http://www.sqlmonster.com
Jul 23 '05 #2

P: n/a

"ceadtinneh" <su*****@yahoo.com> wrote in message
news:11*********************@z14g2000cwz.googlegro ups.com...
Folks,

We're implementing a software based mirroring solution. This solution
requires that the SQL Server service on the target server be stopped
while data is being replicated from the source server.

One problem we encountered while testing was that the SQL Server
Service on the target server was inadvertantly started when users
selected that server in Enterprise Manager. Is there any way to keep
the service from starting through Enterprise Manager?

Thanks


Sure - don't give users permissions to start services on the server, only
sysadmins and DBAs should be able to do that. Starting the MSSQL service (or
any other service) requires operating-system permissions, not MSSQL ones, so
you need to look at it from that angle.

You can also uncheck the "Automatically start SQL Server when connecting"
box in the EM registration properties, but that isn't really addressing the
issue, and won't stop an impatient user starting the service manually.

Simon
Jul 23 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.