By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,415 Members | 1,568 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,415 IT Pros & Developers. It's quick & easy.

ListAvailableSQLServers Problem

P: n/a
I have been using SQLDMO listavailableSQLServers . It displays all the
servers but it doesnt list the local machine in which SQL Server too is
running. Am i missin something?

Jul 23 '05 #1
Share this Question
Share on Google+
11 Replies


P: n/a
What is the local machine?

If it's xp with sp2 then see
http://support.microsoft.com/default.aspx?kbid=841249

Nigel Rivett
www.nigelrivett.net
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Jul 23 '05 #2

P: n/a
What is the local machine?

If it's xp with sp2 then see
http://support.microsoft.com/default.aspx?kbid=841249

Nigel Rivett
www.nigelrivett.net
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Jul 23 '05 #3

P: n/a
What is the local machine?

If it's xp with sp2 then see
http://support.microsoft.com/default.aspx?kbid=841249

Nigel Rivett
www.nigelrivett.net
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Jul 23 '05 #4

P: n/a
What is the local machine?

If it's xp with sp2 then see
http://support.microsoft.com/default.aspx?kbid=841249

Nigel Rivett
www.nigelrivett.net
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Jul 23 '05 #5

P: n/a
What is the local machine?

If it's xp with sp2 then see
http://support.microsoft.com/default.aspx?kbid=841249

Nigel Rivett
www.nigelrivett.net
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Jul 23 '05 #6

P: n/a
What is the local machine?

If it's xp with sp2 then see
http://support.microsoft.com/default.aspx?kbid=841249

Nigel Rivett
www.nigelrivett.net
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Jul 23 '05 #7

P: n/a
What is the local machine?

If it's xp with sp2 then see
http://support.microsoft.com/default.aspx?kbid=841249

Nigel Rivett
www.nigelrivett.net
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Jul 23 '05 #8

P: n/a
What is the local machine?

If it's xp with sp2 then see
http://support.microsoft.com/default.aspx?kbid=841249

Nigel Rivett
www.nigelrivett.net
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Jul 23 '05 #9

P: n/a
What is the local machine?

If it's xp with sp2 then see
http://support.microsoft.com/default.aspx?kbid=841249

Nigel Rivett
www.nigelrivett.net
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Jul 23 '05 #10

P: n/a
no its not XP.. its 2000.
I have installed SQL server in 3 machines in network includin the one
where i am running the application. now with listavailableservers it
shows the other 2 machines but not the one on where i am working on.

Jul 23 '05 #11

P: n/a
Is your local database available over the network? Have you enabled a
network protocal using svrnetcn.exe? I noticed the other day that the
documentation says that ListAvailableSQLServers lists 'network-visible
instances' of SQL Server...

I have been suffering a similar (but different) problem. On XP it
appears to decide that if you are not connected to a network then the
server is not 'network-visible' and therefore the (local) server is not
listed. Hmm...

Any suggestions on how to detect if SQLServer is running on the local
machine when it's not connected to a network?

Neil

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Jul 23 '05 #12

This discussion thread is closed

Replies have been disabled for this discussion.