By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,435 Members | 2,033 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,435 IT Pros & Developers. It's quick & easy.

create relationship with tables in a linked server

P: n/a
js
I need to create a relationship between a local table and tables on a
linked server. I used the design table wizard and selected the
relationship property wizard. In the reslationship property wizard,
the tables that I need to get the keys from in the linked server do not
show up. Is there a way to do this, or I simply don't have enough
permission to tables in the linked server. On the local server, the
Security tab of linked server property has Local Loging "sa", Remote
User "sa" and Remote Password "****". Thanks for your help.

Jul 23 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Hi

You can not create a relationship in this way, you are restricted to
definining FKs to tables in the same database. If you wish to force a
constraint between the local table and the remote one, you can write a
function that can be used in a check constraint or enforce it through
writing a trigger (which may be the faster and easier solution to
implement).

John

"js" <an********@yahoo.com> wrote in message
news:11**********************@z14g2000cwz.googlegr oups.com...
I need to create a relationship between a local table and tables on a
linked server. I used the design table wizard and selected the
relationship property wizard. In the reslationship property wizard,
the tables that I need to get the keys from in the linked server do not
show up. Is there a way to do this, or I simply don't have enough
permission to tables in the linked server. On the local server, the
Security tab of linked server property has Local Loging "sa", Remote
User "sa" and Remote Password "****". Thanks for your help.

Jul 23 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.