By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
432,175 Members | 1,689 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 432,175 IT Pros & Developers. It's quick & easy.

SP3a and strong password problem

P: n/a
I urgently need tom use SP3a upgrade the instance of SQLServer200
MSDE runing on my local machine but I am having problems in doing so.

My first problem is that when I start the set up procedure I get the
message
"A strong SA password is required for security reasons. Please use
SAPWD switch to supply the same"

Currently the sa password is
Abc/def/ghk1

Which I think is a 'strong password' according to the microsoft rules
at
http://www.microsoft.com/resources/d...word_tips.mspx

I would be grateful if someone could confirm that Abc/def/ghk1 is a
strong password.

If anyone could point me to some published informal help on installing
SP3a then that would also be very helpful (I do of course have the MS
read me file). If anyone has a sample command line entry for the
updating then I would find that extremely useful. There is one
instance of MSDE on my machine, named NetSDK.

Best wishes, John Morgan
Jul 23 '05 #1
Share this Question
Share on Google+
6 Replies


P: n/a
John Morgan (jf*@XXwoodlander.co.uk) writes:
I urgently need tom use SP3a upgrade the instance of SQLServer200
MSDE runing on my local machine but I am having problems in doing so.

My first problem is that when I start the set up procedure I get the
message
"A strong SA password is required for security reasons. Please use
SAPWD switch to supply the same"

Currently the sa password is
Abc/def/ghk1


I don't have any experience of upgrading MSDE through command line,
but could the problem be the slashes? /SAPWD=Abc/def/ghkl is taken
as /SAPWD=Abc /def /ghkl. It should work, I think, if you put the
password in qoutes: /SAPWD="Abc/def/ghkl".
--
Erland Sommarskog, SQL Server MVP, es****@sommarskog.se

Books Online for SQL Server SP3 at
http://www.microsoft.com/sql/techinf...2000/books.asp
Jul 23 '05 #2

P: n/a

Thank you Erland,
Is there any way of upgrading MSDE other than through the command
line?

I am having real problems in upgrading
eg since posting the first message I have discovered that since my
installation package is sql2000.msi
I need to go to
http://www.microsoft.com/technet/sec.../msdeapps.mspx for
further information.

I am almost certain that my MSDE was installed with NetSDK but when I
click on the appropriate link on that page i get a 'knowledge base
article unavailable' message.
Best wishes, John Morgan

On Fri, 10 Dec 2004 22:12:51 +0000 (UTC), Erland Sommarskog
<es****@sommarskog.se> wrote:
John Morgan (jf*@XXwoodlander.co.uk) writes:
I urgently need tom use SP3a upgrade the instance of SQLServer200
MSDE runing on my local machine but I am having problems in doing so.

My first problem is that when I start the set up procedure I get the
message
"A strong SA password is required for security reasons. Please use
SAPWD switch to supply the same"

Currently the sa password is
Abc/def/ghk1


I don't have any experience of upgrading MSDE through command line,
but could the problem be the slashes? /SAPWD=Abc/def/ghkl is taken
as /SAPWD=Abc /def /ghkl. It should work, I think, if you put the
password in qoutes: /SAPWD="Abc/def/ghkl".


Jul 23 '05 #3

P: n/a
Hi

I think the easiest way to overcome the problem would be to change the sa
password before the installation. A strong password in this case may only
mean something other than a blank string, other posts say six characters and
two numbers work.

Usually a strong password would require not to have alphabetically
consecutive letters, non keyboard consecutive characters and non
recognisable names (even with numeric substitutions).

John

"John Morgan" <jf*@XXwoodlander.co.uk> wrote in message
news:v7********************************@4ax.com...

Thank you Erland,
Is there any way of upgrading MSDE other than through the command
line?

I am having real problems in upgrading
eg since posting the first message I have discovered that since my
installation package is sql2000.msi
I need to go to
http://www.microsoft.com/technet/sec.../msdeapps.mspx for
further information.

I am almost certain that my MSDE was installed with NetSDK but when I
click on the appropriate link on that page i get a 'knowledge base
article unavailable' message.
Best wishes, John Morgan

On Fri, 10 Dec 2004 22:12:51 +0000 (UTC), Erland Sommarskog
<es****@sommarskog.se> wrote:
John Morgan (jf*@XXwoodlander.co.uk) writes:
I urgently need tom use SP3a upgrade the instance of SQLServer200
MSDE runing on my local machine but I am having problems in doing so.

My first problem is that when I start the set up procedure I get the
message
"A strong SA password is required for security reasons. Please use
SAPWD switch to supply the same"

Currently the sa password is
Abc/def/ghk1


I don't have any experience of upgrading MSDE through command line,
but could the problem be the slashes? /SAPWD=Abc/def/ghkl is taken
as /SAPWD=Abc /def /ghkl. It should work, I think, if you put the
password in qoutes: /SAPWD="Abc/def/ghkl".

Jul 23 '05 #4

P: n/a
Thanks John
I have tried changing the password before upgrading but the problem
persists.

I understand what you say about not having consecutive letters etc in
a password and I of course agree. what I am not sure is whether the
system tests for this sort of thing. I used the quoted password merely
as a temporary measure to try and get the SP3a package working.

I am begining to think that my problems arise because the installation
package SQL2000.msi is not a valid one for SP3a to work. I think the
MSDE was installed when .NetSDK was installed and therefore I am
supposed to go to
http://www.microsoft.com/technet/sec.../msdeapps.mspx for
further information but when I click on the appropriate link on that
page i get a 'knowledge base article unavailable' message.

Best wishes, John Morgan
On Sat, 11 Dec 2004 20:33:11 -0000, "John Bell"
<jb************@hotmail.com> wrote:
Hi

I think the easiest way to overcome the problem would be to change the sa
password before the installation. A strong password in this case may only
mean something other than a blank string, other posts say six characters and
two numbers work.

Usually a strong password would require not to have alphabetically
consecutive letters, non keyboard consecutive characters and non
recognisable names (even with numeric substitutions).

John

"John Morgan" <jf*@XXwoodlander.co.uk> wrote in message
news:v7********************************@4ax.com.. .

Thank you Erland,
Is there any way of upgrading MSDE other than through the command
line?

I am having real problems in upgrading
eg since posting the first message I have discovered that since my
installation package is sql2000.msi
I need to go to
http://www.microsoft.com/technet/sec.../msdeapps.mspx for
further information.

I am almost certain that my MSDE was installed with NetSDK but when I
click on the appropriate link on that page i get a 'knowledge base
article unavailable' message.
Best wishes, John Morgan

On Fri, 10 Dec 2004 22:12:51 +0000 (UTC), Erland Sommarskog
<es****@sommarskog.se> wrote:
John Morgan (jf*@XXwoodlander.co.uk) writes:
I urgently need tom use SP3a upgrade the instance of SQLServer200
MSDE runing on my local machine but I am having problems in doing so.

My first problem is that when I start the set up procedure I get the
message
"A strong SA password is required for security reasons. Please use
SAPWD switch to supply the same"

Currently the sa password is
Abc/def/ghk1
I don't have any experience of upgrading MSDE through command line,
but could the problem be the slashes? /SAPWD=Abc/def/ghkl is taken
as /SAPWD=Abc /def /ghkl. It should work, I think, if you put the
password in qoutes: /SAPWD="Abc/def/ghkl".


Jul 23 '05 #5

P: n/a
Hi John

The installation of MSDE is optional with the .NetSDK therefore you may want
to check that there is a service running for the a NETSDK instance. Also
check the following to make sure that it was the SDK that installed it
http://support.microsoft.com/default...b;en-us;311762 You should
also check what the version number is, to get this see
http://www.aspfaq.com/show.asp?id=2160
The following lists most versions available:
http://www.sqlsecurity.com/DesktopDefault.aspx?tabid=37

It could be that the one of the SDK service packs has upgraded it!

If you know that the msi is you may want to try the /upgradesp option
http://msdn.microsoft.com/library/de...stsql_84xl.asp

If you continue to have problems then the quickest solution may easier be to
back up the databases (and/or detach them). Remove the instance and
re-install from the standard MSDE2000A.exe. See
http://msdn.microsoft.com/netframewo...e/default.aspx, you
can then restore (or re-attach) the databases and then do the upgrade for
this installation. Alternatively you may be able to find the installation
scripts on the SDK cd and reinstall the databases from scratch.

John

"John Morgan" <jf*@XXwoodlander.co.uk> wrote in message
news:gq********************************@4ax.com...
Thanks John
I have tried changing the password before upgrading but the problem
persists.

I understand what you say about not having consecutive letters etc in
a password and I of course agree. what I am not sure is whether the
system tests for this sort of thing. I used the quoted password merely
as a temporary measure to try and get the SP3a package working.

I am begining to think that my problems arise because the installation
package SQL2000.msi is not a valid one for SP3a to work. I think the
MSDE was installed when .NetSDK was installed and therefore I am
supposed to go to
http://www.microsoft.com/technet/sec.../msdeapps.mspx for
further information but when I click on the appropriate link on that
page i get a 'knowledge base article unavailable' message.

Best wishes, John Morgan
On Sat, 11 Dec 2004 20:33:11 -0000, "John Bell"
<jb************@hotmail.com> wrote:
Hi

I think the easiest way to overcome the problem would be to change the sa
password before the installation. A strong password in this case may only
mean something other than a blank string, other posts say six characters
and
two numbers work.

Usually a strong password would require not to have alphabetically
consecutive letters, non keyboard consecutive characters and non
recognisable names (even with numeric substitutions).

John

"John Morgan" <jf*@XXwoodlander.co.uk> wrote in message
news:v7********************************@4ax.com. ..

Thank you Erland,
Is there any way of upgrading MSDE other than through the command
line?

I am having real problems in upgrading
eg since posting the first message I have discovered that since my
installation package is sql2000.msi
I need to go to
http://www.microsoft.com/technet/sec.../msdeapps.mspx for
further information.

I am almost certain that my MSDE was installed with NetSDK but when I
click on the appropriate link on that page i get a 'knowledge base
article unavailable' message.
Best wishes, John Morgan

On Fri, 10 Dec 2004 22:12:51 +0000 (UTC), Erland Sommarskog
<es****@sommarskog.se> wrote:

John Morgan (jf*@XXwoodlander.co.uk) writes:
> I urgently need tom use SP3a upgrade the instance of SQLServer200
> MSDE runing on my local machine but I am having problems in doing so.
>
> My first problem is that when I start the set up procedure I get the
> message
> "A strong SA password is required for security reasons. Please use
> SAPWD switch to supply the same"
>
> Currently the sa password is
> Abc/def/ghk1
>

I don't have any experience of upgrading MSDE through command line,
but could the problem be the slashes? /SAPWD=Abc/def/ghkl is taken
as /SAPWD=Abc /def /ghkl. It should work, I think, if you put the
password in qoutes: /SAPWD="Abc/def/ghkl".

Jul 23 '05 #6

P: n/a
Thanks JOhn for your l reply . I can see I should my current version
of MSDE but first I need to tackle an immediate problem.

The real reason for updating is that I have online SQL Server
databases on an ISP's SQL Server. Within the last fornight the ISP
has suddenly updated the security arrangements for its SQL Server
and now allows only 'access through port 1433'. This has meant that
my Enterprise Manager connection does not now work (has worked
splendidly for 12 months) and I cannot access my online databases
using Enterprise Manager. The ISP have given me simple instructions
to set up an alias using Network Client (on port 1433) and to
register that connection using Enterprise Manager but their
instructions do not work. They say that this is because my MSDE has
not been upgraded to SP3.

The more I think about it and acting too on advice I have received
then my inability to connect to an online SQL database is likely to
have nothing to do with upgrading my current version of MSDE.

I have therefore posted a new topic attempting to explain my problem.
It would be great if you could have a look at it,

Best wishes, John

On Sun, 12 Dec 2004 10:48:05 -0000, "John Bell"
<jb************@hotmail.com> wrote:
Hi John

The installation of MSDE is optional with the .NetSDK therefore you may want
to check that there is a service running for the a NETSDK instance. Also
check the following to make sure that it was the SDK that installed it
http://support.microsoft.com/default...b;en-us;311762 You should
also check what the version number is, to get this see
http://www.aspfaq.com/show.asp?id=2160
The following lists most versions available:
http://www.sqlsecurity.com/DesktopDefault.aspx?tabid=37

It could be that the one of the SDK service packs has upgraded it!

If you know that the msi is you may want to try the /upgradesp option
http://msdn.microsoft.com/library/de...stsql_84xl.asp

If you continue to have problems then the quickest solution may easier be to
back up the databases (and/or detach them). Remove the instance and
re-install from the standard MSDE2000A.exe. See
http://msdn.microsoft.com/netframewo...e/default.aspx, you
can then restore (or re-attach) the databases and then do the upgrade for
this installation. Alternatively you may be able to find the installation
scripts on the SDK cd and reinstall the databases from scratch.

John

"John Morgan" <jf*@XXwoodlander.co.uk> wrote in message
news:gq********************************@4ax.com.. .
Thanks John
I have tried changing the password before upgrading but the problem
persists.

I understand what you say about not having consecutive letters etc in
a password and I of course agree. what I am not sure is whether the
system tests for this sort of thing. I used the quoted password merely
as a temporary measure to try and get the SP3a package working.

I am begining to think that my problems arise because the installation
package SQL2000.msi is not a valid one for SP3a to work. I think the
MSDE was installed when .NetSDK was installed and therefore I am
supposed to go to
http://www.microsoft.com/technet/sec.../msdeapps.mspx for
further information but when I click on the appropriate link on that
page i get a 'knowledge base article unavailable' message.

Best wishes, John Morgan
On Sat, 11 Dec 2004 20:33:11 -0000, "John Bell"
<jb************@hotmail.com> wrote:
Hi

I think the easiest way to overcome the problem would be to change the sa
password before the installation. A strong password in this case may only
mean something other than a blank string, other posts say six characters
and
two numbers work.

Usually a strong password would require not to have alphabetically
consecutive letters, non keyboard consecutive characters and non
recognisable names (even with numeric substitutions).

John

"John Morgan" <jf*@XXwoodlander.co.uk> wrote in message
news:v7********************************@4ax.com ...

Thank you Erland,
Is there any way of upgrading MSDE other than through the command
line?

I am having real problems in upgrading
eg since posting the first message I have discovered that since my
installation package is sql2000.msi
I need to go to
http://www.microsoft.com/technet/sec.../msdeapps.mspx for
further information.

I am almost certain that my MSDE was installed with NetSDK but when I
click on the appropriate link on that page i get a 'knowledge base
article unavailable' message.
Best wishes, John Morgan

On Fri, 10 Dec 2004 22:12:51 +0000 (UTC), Erland Sommarskog
<es****@sommarskog.se> wrote:

>John Morgan (jf*@XXwoodlander.co.uk) writes:
>> I urgently need tom use SP3a upgrade the instance of SQLServer200
>> MSDE runing on my local machine but I am having problems in doing so.
>>
>> My first problem is that when I start the set up procedure I get the
>> message
>> "A strong SA password is required for security reasons. Please use
>> SAPWD switch to supply the same"
>>
>> Currently the sa password is
>> Abc/def/ghk1
>>
>
>I don't have any experience of upgrading MSDE through command line,
>but could the problem be the slashes? /SAPWD=Abc/def/ghkl is taken
>as /SAPWD=Abc /def /ghkl. It should work, I think, if you put the
>password in qoutes: /SAPWD="Abc/def/ghkl".


Jul 23 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.