473,558 Members | 2,876 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

sqlmaint.exe failed

I have a maintenance plan on a client's site, there's only one database
in the plan and it's set to backup db and log, this job fails
consistently. The one step in the job contains this line:

EXECUTE master.dbo.xp_s qlmaint N'-PlanID
392B2334-6800-4655-A6C7-5414D9072505 -WriteHistory -VrfyBackup
-BkUpMedia DISK -BkUpDB "C:\Program Files\Microsoft SQL
Server\MSSQL\BA CKUP\DailyBacku ps" -DelBkUps 4WEEKS -BkExt "BAK"'

Which fails if run in QA with the message:

Server: Msg 22029, Level 16, State 1, Line 0
sqlmaint.exe failed.

I've searched for this error and cannot find anything to help.
There's no "-S" in the path, it writes absolutely no history on the
plan. I set the plan to write history in the log directory on the
server, it wrote nothing to that directory.

The database doesn't get backed up but is able to be backed up manually
to the path specified in the plan. I also have a separate job with a
SQL backup statement in it that works OK so SQLAgent is working.

Sep 11 '05 #1
9 18603
Hi Trevor

I assume you have read
http://support.microsoft.com/default...b;en-us;326485

You may want to look at writing the history to a text file and the option to
do more verbose logging from SQL agent in:
http://support.microsoft.com/kb/288577/

Also check out which database you are applying the plan to:
http://support.microsoft.com/default...b;en-us;303292

You may want to consider writing your own set of maintenance routines that
give you more information.

HTH

John

"Trevor Best" <go**********@b esty.org.uk> wrote in message
news:11******** **************@ z14g2000cwz.goo glegroups.com.. .
I have a maintenance plan on a client's site, there's only one database
in the plan and it's set to backup db and log, this job fails
consistently. The one step in the job contains this line:

EXECUTE master.dbo.xp_s qlmaint N'-PlanID
392B2334-6800-4655-A6C7-5414D9072505 -WriteHistory -VrfyBackup
-BkUpMedia DISK -BkUpDB "C:\Program Files\Microsoft SQL
Server\MSSQL\BA CKUP\DailyBacku ps" -DelBkUps 4WEEKS -BkExt "BAK"'

Which fails if run in QA with the message:

Server: Msg 22029, Level 16, State 1, Line 0
sqlmaint.exe failed.

I've searched for this error and cannot find anything to help.
There's no "-S" in the path, it writes absolutely no history on the
plan. I set the plan to write history in the log directory on the
server, it wrote nothing to that directory.

The database doesn't get backed up but is able to be backed up manually
to the path specified in the plan. I also have a separate job with a
SQL backup statement in it that works OK so SQLAgent is working.

Sep 12 '05 #2
Thanks, I've read the links you provided but none have helped.

I can actually run the plan from an NT command prompt window and the
backup runs OK and the plan exits with code 0 (success).

It's just running from the SQLAgent or from Query analyser it fails
immediately without having done anything. It's as though it just can't
execute sqlmaint.exe. I can run other xps such as xp_msver without
trouble so I'm sure the paths are correct.

I checked HKLM\SOFTWARE\M icrosoft\MSSQLS erver\Setup (not where the
first link says it is) and the path is set correctly.

Sep 12 '05 #3
Hi

That would imply permissions is an issue, have you changed the service
account or directory permissions/locations?

John

"Trevor Best" <go**********@b esty.org.uk> wrote in message
news:11******** **************@ g14g2000cwa.goo glegroups.com.. .
Thanks, I've read the links you provided but none have helped.

I can actually run the plan from an NT command prompt window and the
backup runs OK and the plan exits with code 0 (success).

It's just running from the SQLAgent or from Query analyser it fails
immediately without having done anything. It's as though it just can't
execute sqlmaint.exe. I can run other xps such as xp_msver without
trouble so I'm sure the paths are correct.

I checked HKLM\SOFTWARE\M icrosoft\MSSQLS erver\Setup (not where the
first link says it is) and the path is set correctly.

Sep 12 '05 #4

"Trevor Best" <go**********@b esty.org.uk> wrote in message
news:11******** **************@ g14g2000cwa.goo glegroups.com.. .
Thanks, I've read the links you provided but none have helped.

I can actually run the plan from an NT command prompt window and the
backup runs OK and the plan exits with code 0 (success).

It's just running from the SQLAgent or from Query analyser it fails
immediately without having done anything. It's as though it just can't
execute sqlmaint.exe. I can run other xps such as xp_msver without
trouble so I'm sure the paths are correct.

I checked HKLM\SOFTWARE\M icrosoft\MSSQLS erver\Setup (not where the
first link says it is) and the path is set correctly.
Almot definitely then SQLAgent is NOT running under a domain account that
has access to the path you're specifying.


Sep 13 '05 #5
The services are running under the local system account and that has
full access to the path specified.

SQLAgent can back up to the path using just a "backup database" command.

Sep 13 '05 #6
Hi

You could prove this by temporarily changing the account or to a lesser
degree by changing the directory.

John

"Trevor Best" <go**********@b esty.org.uk> wrote in message
news:11******** *************@g 43g2000cwa.goog legroups.com...
The services are running under the local system account and that has
full access to the path specified.

SQLAgent can back up to the path using just a "backup database" command.

Sep 14 '05 #7
I tried backing up to a different directory (c:\backup) where another
SQLAgent job successfully backs up using just a "backup database"
command, the backup database command works in this directory but the
maintenance plan doesn't.

I will see if I can get their IT guy to make SQLServer and SQLAgent to
run as Administrator user and see if that helps.

Sep 15 '05 #8
Hi Trevor

That would rule out permissions for the account.

Do you know what type of backup the maintenance plan is doing?

Have you tried dropping the plan and creating a new one?

John

"Trevor Best" <go**********@b esty.org.uk> wrote in message
news:11******** **************@ g49g2000cwa.goo glegroups.com.. .
I tried backing up to a different directory (c:\backup) where another
SQLAgent job successfully backs up using just a "backup database"
command, the backup database command works in this directory but the
maintenance plan doesn't.

I will see if I can get their IT guy to make SQLServer and SQLAgent to
run as Administrator user and see if that helps.

Sep 15 '05 #9
John Bell wrote:
Hi Trevor

That would rule out permissions for the account.

Do you know what type of backup the maintenance plan is doing?

Have you tried dropping the plan and creating a new one?


Yes, that didn't help.

I got the client to reboot their server in the end, this seemed to have
cured the problem.

Thanks for the advice.
Sep 22 '05 #10

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

3
2632
by: mo | last post by:
The code I've pasted below is taken directly from Microsoft's site at http://support.microsoft.com/default.aspx?scid=kb;EN-US;308157 As far as I can tell the error is raised on this line: conn = New SqlConnection("server=MyServer;Integrated Security=SSPI;database=pubs") If I use the code as is, I get the error above. The code only works...
1
3429
by: saiyou | last post by:
Hi! I have a SQL 7.0. The backups created by maintenance plan worked very well before someone shut down the server to do some server maintenance. After restart the server, the backup job is not working any more. All the backups created by maintenance plan are not working, including the newely created one. The message is " Server: Msg 22029,...
0
2080
by: Jeff Reed | last post by:
I am experiencing the the problem outlined the below. Unfortunately, I am using WinXP and I not sure if I can apply the solution due to lack of security control Any feed back would be apreciated http://support.microsoft.com/default.aspx?scid=kb;EN-US;31795 FIX: "Failed to Start Monitoring Directory Changes" Error Message When You Browse...
9
3189
by: Tim D | last post by:
Hi, I originally posted this as a reply to a rather old thread in dotnet.framework.general and didn't get any response. I thought it might be more relevant here; anyone got any ideas? My questions are below... "David Good" wrote: > We have a network running both Win2k and Win2k3 webservers and our web sites > reside on a UNC network...
9
2739
by: Bijoy Naick | last post by:
I've implemented forms authentication and authorization on my application. In my Web.Config, my authorization section looks like this.. <authorization> <allow roles="admin" /> <deny users="*" /> </authorization> If an authenticated user, who is NOT designated the role "admin" attempts to access this folder, he/she is simply redirected...
13
1005
by: Adam | last post by:
Trying to get an asp.net 2.0 app running and am receiving this error. I see a bunch of people with this error on the net, but no solution: Works fine on my local machine, deployed to a server it yields this message. Failed to map the path '/App_GlobalResources/' Stack trace: at...
2
7681
by: news | last post by:
I just upgraded to PHP 4.4.2 on my Slackware 10.2 system. And Apache/mySQL/PHP all work great through a browser. No errors. But when I try to run a PHP script through the command line, which I need to do, I get blocks of errors like: root@slackserve:/var/www/htdocs# php ./phptest.php PHP Warning: Unknown(): Unable to load dynamic library...
2
9739
by: Dennis | last post by:
I'm getting the following problem occasionally...the application will work perfectly well for a period of time and then this pops up. I have tried turning off the default proxy in the web.config which I had seen on other posts but that did not solve the problem. Any assistance or ideas would be appreciated Thanks
1
4679
by: kencana | last post by:
Hi all, I was wondering why I always get "failed to open stream: HTTP request failed!" error in either loading a normal or xml file. i don't understand why i can't get the whole result. the result i get is only some part of the respective url (the one i tried to load). The following is my php code to open the file: $file=...
0
7629
marktang
by: marktang | last post by:
ONU (Optical Network Unit) is one of the key components for providing high-speed Internet services. Its primary function is to act as an endpoint device located at the user's premises. However, people are often confused as to whether an ONU can Work As a Router. In this blog post, we’ll explore What is ONU, What Is Router, ONU & Router’s main...
0
7835
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. ...
0
8061
jinu1996
by: jinu1996 | last post by:
In today's digital age, having a compelling online presence is paramount for businesses aiming to thrive in a competitive landscape. At the heart of this digital strategy lies an intricately woven tapestry of website design and digital marketing. It's not merely about having a website; it's about crafting an immersive digital experience that...
1
7593
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For...
0
7914
tracyyun
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the...
0
6183
agi2029
by: agi2029 | last post by:
Let's talk about the concept of autonomous AI software engineers and no-code agents. These AIs are designed to manage the entire lifecycle of a software development project—planning, coding, testing, and deployment—without human intervention. Imagine an AI that can take a project description, break it down, write the code, debug it, and then...
0
3602
by: TSSRALBI | last post by:
Hello I'm a network technician in training and I need your help. I am currently learning how to create and manage the different types of VPNs and I have a question about LAN-to-LAN VPNs. The last exercise I practiced was to create a LAN-to-LAN VPN between two Pfsense firewalls, by using IPSEC protocols. I succeeded, with both firewalls in...
0
3578
by: adsilva | last post by:
A Windows Forms form does not have the event Unload, like VB6. What one acts like?
1
1164
muto222
by: muto222 | last post by:
How can i add a mobile payment intergratation into php mysql website.

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.