By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,923 Members | 1,655 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,923 IT Pros & Developers. It's quick & easy.

Cannot run any multiprocessing script in PythonWin

P: 1
I run these basic codes in Python 2.6 interactive window of PythonWin which imports multiprocessing module:-
Expand|Select|Wrap|Line Numbers
  1.     >>> import multiprocessing
  2.     >>> def myfunc():
  3.     ...     pass
  4.     ... 
  5.     >>> p1 = multiprocessing.Process(name='listen', target=myfunc)
  6.     >>> p1.start()
  7.     >>> 
  8.  
As soon as I call p1.start(), a popup message comes up (with title "Python for Win32") saying "Could not load the file from <myfileName>-c"
where <myfileName> is my file name with full path.
Also this popup message opens in a new PythonWin window. After a long time (1 min), a "Python Tracekack" window opens up showing -
"Traceback (most recent call last):
File "C:\Python26\Lib\site-packages\Pythonwin\pywin\framework\intpyapp.py", line 245, in ProcessArgs
dde.Exec("win32ui.GetApp().OpenDocumentFile(%s)" % (repr(fname)))
error: Exec failed"

When I run any multiprocessing script (which obviously calls Process.start() ) from command prompt, it seems to run perfectly without any trouble.

I couldn't find anything online related to this problem.
Thanks for the help!!

Amit
P.S:
I am running it on Windows XP, PythonWin, Python 2.6.4v
Dec 30 '10 #1
Share this question for a faster answer!
Share on Google+

Post your reply

Sign in to post your reply or Sign up for a free account.