By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
454,525 Members | 1,623 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 454,525 IT Pros & Developers. It's quick & easy.

disable ctrl-P in idle?

P: n/a
Is there a way to disable ctrl-P (print window) in IDLE? I'm editing
some python code in IDLE and I keep hitting this by mistake from my
years of emacs editing.

Thanks in advance.
Nov 10 '08 #1
Share this Question
Share on Google+
9 Replies


P: n/a
On Mon, 10 Nov 2008 10:40:28 -0800 (PST), "timw.google"
<tj******@yahoo.comwrote:
>Is there a way to disable ctrl-P (print window) in IDLE? I'm editing
some python code in IDLE and I keep hitting this by mistake from my
years of emacs editing.

Thanks in advance.
Try autohotkey and map it to something else. Like, nothing :-)

Internally, I don't think so, it's part of CUI.

-- Bob
Nov 10 '08 #2

P: n/a
On Mon, 10 Nov 2008 20:56:46 +0100, Robert Singer <rsinger@____.com>
wrote:
>On Mon, 10 Nov 2008 10:40:28 -0800 (PST), "timw.google"
<tj******@yahoo.comwrote:
>>Is there a way to disable ctrl-P (print window) in IDLE? I'm editing
some python code in IDLE and I keep hitting this by mistake from my
years of emacs editing.

Thanks in advance.

Try autohotkey and map it to something else. Like, nothing :-)

Internally, I don't think so, it's part of CUI.

-- Bob
.... continue:
Or, you can just continue using emacs. I'm using vim, and can't think
of a single reason why I should change it for idle.

-- Bob
Nov 10 '08 #3

P: n/a
On Nov 10, 2:57*pm, Robert Singer <rsinger@____.comwrote:
On Mon, 10 Nov 2008 20:56:46 +0100, Robert Singer <rsinger@____.com>
wrote:
On Mon, 10 Nov 2008 10:40:28 -0800 (PST), "timw.google"
<tjand...@yahoo.comwrote:
>Is there a way to disable ctrl-P (print window) in IDLE? I'm editing
some python code in IDLE and I keep hitting this by mistake from my
years of emacs editing.
>Thanks in advance.
Try autohotkey and map it to something else. Like, nothing :-)
Internally, I don't think so, it's part of CUI.
-- Bob

... continue:
Or, you can just continue using emacs. I'm using vim, and can't think
of a single reason why I should change it for idle.

-- Bob
Thanks. I on a XP box now, and it's a pain to get things installed
here. That's why I'm not using emacs. When I'm on Linux, I use emacs.
It's not worth the trouble to install something else for just this.
Nov 10 '08 #4

P: n/a
On Nov 10, 3:27*pm, "timw.google" <tjand...@yahoo.comwrote:
On Nov 10, 2:57*pm, Robert Singer <rsinger@____.comwrote:
On Mon, 10 Nov 2008 20:56:46 +0100, Robert Singer <rsinger@____.com>
wrote:
>On Mon, 10 Nov 2008 10:40:28 -0800 (PST), "timw.google"
><tjand...@yahoo.comwrote:
>>Is there a way to disable ctrl-P (print window) in IDLE? I'm editing
>>some python code in IDLE and I keep hitting this by mistake from my
>>years of emacs editing.
>>Thanks in advance.
>Try autohotkey and map it to something else. Like, nothing :-)
>Internally, I don't think so, it's part of CUI.
>-- Bob
... continue:
Or, you can just continue using emacs. I'm using vim, and can't think
of a single reason why I should change it for idle.
-- Bob

Thanks. I on a XP box now, and it's a pain to get things installed
here. That's why I'm not using emacs. When I'm on Linux, I use emacs.
It's not worth the trouble to install something else for just this.
It is not more difficult to install emacs on XP. What makes you think
that?
Nov 10 '08 #5

P: n/a
On Mon, 10 Nov 2008 13:53:40 -0800 (PST), dr******@gmail.com <dr******@gmail.comwrote:
On Nov 10, 3:27*pm, "timw.google" <tjand...@yahoo.comwrote:
>On Nov 10, 2:57*pm, Robert Singer <rsinger@____.comwrote:
....
Or, you can just continue using emacs. I'm using vim, and can't think
of a single reason why I should change it for idle.
>Thanks. I on a XP box now, and it's a pain to get things installed
here. That's why I'm not using emacs. When I'm on Linux, I use emacs.
It's not worth the trouble to install something else for just this.

It is not more difficult to install emacs on XP. What makes you think
that?
Yeah. To me, it has just been a matter of unzipping emacs-x.y.z.zip
somewhere, placing my .emacs somewhere where emacs searches for it,
tell it to use the Lucida Console font and type away. As far as I can
tell, there is no need to be local admin.

(Of course, timw's employer might forbid Downloading Dangerous
Unlicenced Freeware from the Internet -- but be got IDLE somehow,
didn't he?)

/Jorgen

--
// Jorgen Grahn <grahn@ Ph'nglui mglw'nafh Cthulhu
\X/ snipabacken.se R'lyeh wgah'nagl fhtagn!
Nov 10 '08 #6

P: n/a
On Mon, 10 Nov 2008 12:27:22 -0800 (PST), "timw.google"
<tj******@yahoo.comwrote:
>
Thanks. I on a XP box now, and it's a pain to get things installed
here. That's why I'm not using emacs. When I'm on Linux, I use emacs.
It's not worth the trouble to install something else for just this.
Actually, it's not necessary to install it. It's just unzip&start
program. You'll figure out how to do the mapping in no time (one
line). After that compile the script (autohotkey) to an exe file, and
you can delete the rest of the stuff.
Just start the exe file, before starting idle.
But, as I can see, RichardT solved the problem already :-)
(yeah, I could've puted this at the beggining of the post, and saved
you the trouble of reading the rest :-)

-- Bob
Nov 11 '08 #7

P: n/a
On Nov 10, 4:49*pm, RichardT <Richa...@invalid.invalidwrote:
On Mon, 10 Nov 2008 10:40:28 -0800 (PST), "timw.google"

<tjand...@yahoo.comwrote:
Is there a way to disable ctrl-P (print window) in IDLE? I'm editing
some python code in IDLE and I keep hitting this by mistake from my
years of emacs editing.
Thanks in advance.

In Idle, select 'Configure IDLE..' from the options menu.

In the Options dialog, select the Keys tab.

Scroll down to the 'print-window' entry and select it.

Click the "Get New Keys For Selection" button.

Select the new key combination e.g. Shift+Ctrl+p and click OK button.

If you have not enter any custom keys before, you will get a prompt
for a Custom Key Set Name - enter a name and click OK.
For the archive, since our hero prefers not to receive credit.
Ctrl+P should no longer send the window to the printer. On my system
(python 2.5.1 on XP) it now moves the cursor up a line for some reason
(deafult binding for the widget?)
Cursor up is the default emacs binding for Ctrl+P so this will
probably please the original poster (and me too!)

Nov 11 '08 #8

P: n/a
On Nov 10, 4:53*pm, "drobi...@gmail.com" <drobi...@gmail.comwrote:
On Nov 10, 3:27*pm, "timw.google" <tjand...@yahoo.comwrote:
On Nov 10, 2:57*pm, Robert Singer <rsinger@____.comwrote:
On Mon, 10 Nov 2008 20:56:46 +0100, Robert Singer <rsinger@____.com>
wrote:
On Mon, 10 Nov 2008 10:40:28 -0800 (PST), "timw.google"
<tjand...@yahoo.comwrote:
>Is there a way to disable ctrl-P (print window) in IDLE? I'm editing
>some python code in IDLE and I keep hitting this by mistake from my
>years of emacs editing.
>Thanks in advance.
Try autohotkey and map it to something else. Like, nothing :-)
Internally, I don't think so, it's part of CUI.
-- Bob
... continue:
Or, you can just continue using emacs. I'm using vim, and can't think
of a single reason why I should change it for idle.
-- Bob
Thanks. I on a XP box now, and it's a pain to get things installed
here. That's why I'm not using emacs. When I'm on Linux, I use emacs.
It's not worth the trouble to install something else for just this.

It is not more difficult to install emacs on XP. What makes you think
that?
It's not that it's technically difficult. It's just a hassle to
involve the help desk.
Nov 11 '08 #9

P: n/a
On Nov 10, 10:35*pm, "drobi...@gmail.com" <drobi...@gmail.comwrote:
On Nov 10, 4:49*pm, RichardT <Richa...@invalid.invalidwrote:
On Mon, 10 Nov 2008 10:40:28 -0800 (PST), "timw.google"
<tjand...@yahoo.comwrote:
>Is there a way to disable ctrl-P (print window) in IDLE? I'm editing
>some python code in IDLE and I keep hitting this by mistake from my
>years of emacs editing.
>Thanks in advance.
In Idle, select 'Configure IDLE..' from the options menu.
In the Options dialog, select the Keys tab.
Scroll down to the 'print-window' entry and select it.
Click the "Get New Keys For Selection" button.
Select the new key combination e.g. Shift+Ctrl+p and click OK button.
If you have not enter any custom keys before, you will get a prompt
for a Custom Key Set Name - enter a name and click OK.

For the archive, since our hero prefers not to receive credit.
Ctrl+P should no longer send the window to the printer. On my system
(python 2.5.1 on XP) it now moves the cursor up a line for some reason
(deafult binding for the widget?)

Cursor up is the default emacs binding for Ctrl+P so this will
probably please the original poster (and me too!)
Wonderful!!!!! I remapped ctrl-N too while I was at it. Thanks!!!!

(and no help desk involvement either!)
Nov 11 '08 #10

This discussion thread is closed

Replies have been disabled for this discussion.