By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
457,949 Members | 1,426 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 457,949 IT Pros & Developers. It's quick & easy.

Python IDLE and Access Denied

P: n/a
I had just finished working with IDLE, and tried to double-click on a py
file. It produced an OK dialog with the path to the file and the msg "access
denied." All my py files act that way. I rebooted and the same thing
continues. I copied one py program to another computer, and accessed it
there. Python 2.4. Suggestions?
--
W. eWatson

(121.015 Deg. W, 39.262 Deg. N) GMT-8 hr std. time)
Obz Site: 39 15' 7" N, 121 2' 32" W, 2700 feet

Web Page: <www.speckledwithstars.net/>

Oct 14 '08 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Dennis Lee Bieber wrote:
On Mon, 13 Oct 2008 19:07:06 -0700, "W. eWatson"
<no*******@sbcglobal.netdeclaimed the following in comp.lang.python:
>I had just finished working with IDLE, and tried to double-click on a py
file. It produced an OK dialog with the path to the file and the msg "access
denied." All my py files act that way. I rebooted and the same thing
continues. I copied one py program to another computer, and accessed it
there. Python 2.4. Suggestions?

Off-hand, I'd suspect some of your mistakes in trying to get a
console to run Python programs has left the association between .py and
the Python interpreter in a mess.

Go back to the console and enter

ftype python.file

exactly -- nothing else, and see what it displays. If it looks anything
other than (change the E: to whatever your installation uses)

C:\Documents and Settings\Dennis Lee Bieber>ftype python.file
python.file="E:\Python24\python.exe" "%1" %*

then you'll need to change it... (again ensure the path is correct)

ftype python.file="E:\Python24\python.exe" "%1" %*
The other place to explore would be from a directory window:
Tools/Folder Options/File Types

Find PY, click [advanced], select open, click [edit]

In the "Application used..." box, you should see (again, adjust for
your path)

"E:\Python24\python.exe" "%1" %*
[x] use DDE
Application: Python
Topic: System

(Hmmm, I don't recall if DDE is really applicable, but that's what mine
shows).

Thanks, again, but this one mysteriously disappeared. I managed to open my
py file into IDLE and saved it to see if that would work. It did and all is
well.

--
W. eWatson

(121.015 Deg. W, 39.262 Deg. N) GMT-8 hr std. time)
Obz Site: 39 15' 7" N, 121 2' 32" W, 2700 feet

Web Page: <www.speckledwithstars.net/>

Oct 14 '08 #2

P: n/a
W. eWatson wrote:
Dennis Lee Bieber wrote:
>On Mon, 13 Oct 2008 19:07:06 -0700, "W. eWatson"
<no*******@sbcglobal.netdeclaimed the following in comp.lang.python:
>>I had just finished working with IDLE, and tried to double-click on a
py file. It produced an OK dialog with the path to the file and the
msg "access denied." All my py files act that way. I rebooted and the
same thing continues. I copied one py program to another computer,
and accessed it there. Python 2.4. Suggestions?

Off-hand, I'd suspect some of your mistakes in trying to get a
console to run Python programs has left the association between .py and
the Python interpreter in a mess.

Go back to the console and enter

ftype python.file

exactly -- nothing else, and see what it displays. If it looks anything
other than (change the E: to whatever your installation uses)

C:\Documents and Settings\Dennis Lee Bieber>ftype python.file
python.file="E:\Python24\python.exe" "%1" %*

then you'll need to change it... (again ensure the path is correct)

ftype python.file="E:\Python24\python.exe" "%1" %*
The other place to explore would be from a directory window:
Tools/Folder Options/File Types

Find PY, click [advanced], select open, click [edit]

In the "Application used..." box, you should see (again, adjust for
your path)

"E:\Python24\python.exe" "%1" %* [x] use DDE
Application: Python
Topic: System

(Hmmm, I don't recall if DDE is really applicable, but that's what mine
shows).

Thanks, again, but this one mysteriously disappeared. I managed to open
my py file into IDLE and saved it to see if that would work. It did and
all is well.
Well, the story isn't quite over. I discovered the message appears only
outside of Idle. However, within Idle it can read and save the file. My
guess is that it's more likely the matplotlib install went haywire, or a
week before this a disk failure caused the problem. By pure luck, I managed
to restore the drive. In any case, I can still proceed.
--
W. eWatson

(121.015 Deg. W, 39.262 Deg. N) GMT-8 hr std. time)
Obz Site: 39 15' 7" N, 121 2' 32" W, 2700 feet

Web Page: <www.speckledwithstars.net/>

Oct 14 '08 #3

This discussion thread is closed

Replies have been disabled for this discussion.