By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
458,020 Members | 1,297 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 458,020 IT Pros & Developers. It's quick & easy.

Running IDLE on 3.0rc1

P: n/a
I have not seen this posted, so...
To run IDLE with Python3.0rc1,
edit Python30/Libs/idlelib/run.py,
and change "set_daemon(True)" to "daemon = True" and save.
(This is about line 75, and the only appearance of 'daemon'.)
Otherwise, you get error message about not starting a subprocess.

tjr

Sep 26 '08 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Allan wrote:
Terry Reedy <tj*****@udel.eduwrites:
>I have not seen this posted, so...
To run IDLE with Python3.0rc1,
edit Python30/Libs/idlelib/run.py,
and change "set_daemon(True)" to "daemon = True" and save.
(This is about line 75, and the only appearance of 'daemon'.)
Otherwise, you get error message about not starting a subprocess.
Is this related to the tip at the end of the built-in help file in IDLE
regarding the `-n' command option?
No, the above is a bug fix that did not make it into rc1 but has now
been committed. It arose because the interface of a class in one of the
modules was changed from .set_var(val) to .var = val and the need to
change IDLE was not caught. I imagine that checking that IDLE runs in
not in the test suite.

Sep 27 '08 #2

This discussion thread is closed

Replies have been disabled for this discussion.