472,354 Members | 1,605 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 472,354 software developers and data experts.

Completely unable to install Python on Windows

I'm attempting to install Python 2.5.2 (python-2.5.2.amd64.msi) on my
Vista SP1 x64 system, but the installer always crashes with a "Windows
Installer has stopped working" error after clicking Next on the
initial screen.

I've tried the following so far:

1. x86 and x64 versions
2. Manually reinstalling Windows Installer 4.5
3. Forcing msiexec to run as administrator
4. Installing both globally and for my user alone
5. Silent install
6. The previous version (2.5.1)
7. Repeating the above with a completely clean install of Vista SP1
x64 in VMWare

It seems that no matter what I do, the problem persists. ActivePython
produces a similar error, but much later in the install.

This has me completely baffled, since nobody else seems to have a
similar issue despite it happening on a completely stock install of
Windows. Any help would be greatly appreciated.

- Josh

(The output of msiexec with logging enabled follows)

=== Logging started: 02/09/2008 23:11:12 ===
Action 23:11:12: INSTALL.
Action start 23:11:12: INSTALL.
Action 23:11:12: LaunchConditions. Evaluating launch conditions
Action start 23:11:12: LaunchConditions.
Action ended 23:11:12: LaunchConditions. Return value 1.
Action 23:11:12: WhichUsersDlg.
Action start 23:11:12: WhichUsersDlg.
Info 2898. For VerdanaBold10 textstyle, the system created a 'Verdana'
font, in 1 character set, of 16 pixels height.
Info 2898. For DlgFont8 textstyle, the system created a 'Tahoma' font,
in 1 character set, of 14 pixels height.
Action 23:11:12: WhichUsersDlg. Dialog created
Action ended 23:11:14: WhichUsersDlg. Return value 1.
Action 23:11:14: FindRelatedProducts. Searching for related applications
Action start 23:11:14: FindRelatedProducts.
Action ended 23:11:14: FindRelatedProducts. Return value 1.
Action 23:11:14: AppSearch. Searching for installed applications
Action start 23:11:14: AppSearch.
Action ended 23:11:14: AppSearch. Return value 1.
Action 23:11:14: CCPSearch. Searching for qualifying products
Action start 23:11:14: CCPSearch.
Action ended 23:11:14: CCPSearch. Return value 1.
Action 23:11:14: RMCCPSearch. Searching for qualifying products
Action start 23:11:14: RMCCPSearch.
Action ended 23:11:14: RMCCPSearch. Return value 0.
Action 23:11:14: ValidateProductID.
Action start 23:11:14: ValidateProductID.
Action ended 23:11:14: ValidateProductID. Return value 1.
Action 23:11:14: InitialTargetDir.
Action start 23:11:14: InitialTargetDir.
Action ended 23:11:14: InitialTargetDir. Return value 1.
Action 23:11:14: SetDLLDirToSystem32.
Action start 23:11:14: SetDLLDirToSystem32.
Action ended 23:11:14: SetDLLDirToSystem32. Return value 1.
Action 23:11:14: CostInitialize. Computing space requirements
Action start 23:11:14: CostInitialize.
Action ended 23:11:14: CostInitialize. Return value 1.
Action 23:11:14: FileCost. Computing space requirements
Action start 23:11:14: FileCost.
Action ended 23:11:14: FileCost. Return value 1.
Action 23:11:14: IsolateComponents.
Action start 23:11:14: IsolateComponents.
Action ended 23:11:14: IsolateComponents. Return value 1.
Action 23:11:14: CostFinalize. Computing space requirements
Action start 23:11:14: CostFinalize.
Action ended 23:11:14: CostFinalize. Return value 1.
Action 23:11:14: MigrateFeatureStates. Migrating feature states from
related applications
Action start 23:11:14: MigrateFeatureStates.
Action ended 23:11:14: MigrateFeatureStates. Return value 0.
Action 23:11:14: SelectDirectoryDlg.
Action start 23:11:14: SelectDirectoryDlg.
Sep 2 '08 #1
0 1409

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

by: Richard Hanson | last post by:
Over the last few days, I reinstalled Win2kSP2 to a spare harddrive I had just swapped into my Fujitsu LifeBook P1120 (long story <wink>). Subsequently, I DL'ed the newest Python alpha (2.4a2), and...
by: Peter Gomis | last post by:
I have encountered a situation where I am unable to remove a .NET assembly from the GAC. The message I receive is "Assembly 'assemblyname' could not be uninstalled because it is required by other...
by: Carlos G Benevides | last post by:
I have a ASP.Net web application that has two assemblies that run under com+. Under Windows 2000 the two assemblies are added to com+ automatically when instantiated from the web site. For this...
by: TM | last post by:
When I run an ASP.Net application I am getting the following error: "Error while trying to run project: Unable to start debugging on the web server. The project is not configured to be debugged."...
by: EP | last post by:
When running my asp.net hosting service (asp.net without IIS), on server 2003 with IIS not installed, I get the following when trying to process a request. "System.DllNotFoundException: Unable to...
by: DJTN | last post by:
I'm getting the following error when I try to compile my setup project in VS 2002. I have re-installed the .net framework 1.1 and it didnt solve the problem. WARNING: Unable to find dependency...
by: Izzy | last post by:
I created a windows service using VS 2005 in VB.NET and it runs on my Windows XP Pro machine just fine, now I'm want to install it on one of my servers which is a Windows 2000 Terminal server...
by: luis | last post by:
Hi On Windows xp sp2 and python 2.4 Yesterday I running old versions of gdal, and I try to upgrade I download gdalwin32exe150.zip and gdal-python-13.win32-py2.4.exe I unzip...
by: globalrev | last post by:
type "python setup.py install" that is used in most "addons" for python. well using windows vista, where the h*** am i supposed to type this? if it is not doable in windows, what do i have...
by: Kemmylinns12 | last post by:
Blockchain technology has emerged as a transformative force in the business world, offering unprecedented opportunities for innovation and efficiency. While initially associated with cryptocurrencies...
by: Matthew3360 | last post by:
Hi there. I have been struggling to find out how to use a variable as my location in my header redirect function. Here is my code. header("Location:".$urlback); Is this the right layout the...
by: Matthew3360 | last post by:
Hi, I have a python app that i want to be able to get variables from a php page on my webserver. My python app is on my computer. How would I make it so the python app could use a http request to get...
by: Arjunsri | last post by:
I have a Redshift database that I need to use as an import data source. I have configured the DSN connection using the server, port, database, and credentials and received a successful connection...
by: Matthew3360 | last post by:
Hi, I have been trying to connect to a local host using php curl. But I am finding it hard to do this. I am doing the curl get request from my web server and have made sure to enable curl. I get a...
by: Oralloy | last post by:
Hello Folks, I am trying to hook up a CPU which I designed using SystemC to I/O pins on an FPGA. My problem (spelled failure) is with the synthesis of my design into a bitstream, not the C++...
by: Carina712 | last post by:
Setting background colors for Excel documents can help to improve the visual appeal of the document and make it easier to read and understand. Background colors can be used to highlight important...
by: Rahul1995seven | last post by:
Introduction: In the realm of programming languages, Python has emerged as a powerhouse. With its simplicity, versatility, and robustness, Python has gained popularity among beginners and experts...
by: Ricardo de Mila | last post by:
Dear people, good afternoon... I have a form in msAccess with lots of controls and a specific routine must be triggered if the mouse_down event happens in any control. Than I need to discover what...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.