469,362 Members | 2,367 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,362 developers. It's quick & easy.

Boost Python DLL from Boost Pro is built incorrectly?

I'm having issues with Boost Python, downloaded via http://www.boostpro.com.
I *think* it's related to WinXP side by side assemblies. My
application that uses Boost Python fails to start.

I ran dependancy walker on the Boost Python DLL and I get the
following:

Error: The Side-by-Side configuration information for "c:\data\excds
\test adaptation\BOOST_PYTHON-VC80-MT-1_35.DLL" contains errors. This
application has failed to start because the application configuration
is incorrect. Reinstalling the application may fix this problem
(14001).
Error: At least one required implicit or forwarded dependency was not
found.
Warning: At least one delay-load dependency module was not found.
Warning: At least one module has an unresolved import due to a missing
export function in a delay-load dependent module.

I removed the installation of the 1.35 binaries and reverted to
1.34.1, rebuilt my app and it works fine. So I think there's a problem
with the 1.35 Boost Python DLL from Boost Pro. Could someone verify?

Thanks
Aug 20 '08 #1
0 1130

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

226 posts views Thread by Stephen C. Waterbury | last post: by
reply views Thread by Natsu Mizutani | last post: by
205 posts views Thread by Jeremy Siek | last post: by
reply views Thread by Andrew Ayre | last post: by
4 posts views Thread by JDJMSon | last post: by
1 post views Thread by Max Wilson | last post: by
reply views Thread by Kurt B. Kaiser | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by suresh191 | last post: by
1 post views Thread by Marylou17 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.