By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
448,812 Members | 1,647 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 448,812 IT Pros & Developers. It's quick & easy.

Can't get Python for Windows to run

P: n/a
I have Python 2.5 working just fine on my system.

I've tried downloading and installing the MS Windows Python
extensions, but can't get pythonw.exe (that's the windows executable,
right?) to do anything. I double-click it, nothing happens. I run it
from a command prompt, it just returns me to the command prompt.

The only possible clue I have is that the installation process
produced the error message:

"Can't install shortcuts - 'C:\\Documents and Settings\\All
Users\\Start Menu\\Programs\\Python 2.5' is not a folder"

That's right, it isn't a folder -- the relevant folder would have been
C:\\Documents and Settings\\All Users\\Start
Menu\\Programs\\Programming\\Python 2.5'

but the installer never gave me the chance to choose that.

That woudn't stop me running Pythonw directly from the folder in which
it's installed, though, would it?

--
Tim Rowe
Jul 4 '08 #1
Share this Question
Share on Google+
1 Reply


P: n/a
On Fri, 04 Jul 2008 16:19:34 +0100, Tim Rowe wrote:
pythonw.exe (that's the windows executable, right?)
python.exe and pythonw.exe are both Windows executables. There are no non-
Windows executables in a Python for Windows package.

python.exe is used for console apps or interactive sessions.

pythonw.exe suppresses the console window. You use it to launch GUI apps
that don't need a console. You can't use it for an interactive session,
and it makes no sense to start it without also specifying a Python
program to run.

Python source files named with the ".pyw" extension are associated with
pythonw.exe, while ".py" is associated with python.exe.

--
09 F9 11 02 9D 74 E3 5B D8 41 56 C5 63 56 88 C0 -- pass it on
Jul 5 '08 #2

This discussion thread is closed

Replies have been disabled for this discussion.