By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
464,553 Members | 1,018 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 464,553 IT Pros & Developers. It's quick & easy.

Problem setting cookie in Internet Explorer

P: n/a
Hi,

I'm using the python to set a cookie when a user logs in. Thing is it
doesn't seem to be setting properly in Internet Explorer. It works
grand in Firefox. Its basically:

c = Cookie.SimpleCookie()

c['username'] = uname

c['password'] = pword

print c

print pageContent

And thats it. I've a suspicion that it could be something to do with
the expiry time of the cookie. But I'm really not sure and don't
really know where to go with it. I've tried it on Internet Explorer on
2 machines and get the same problem.

Thanks for any help...
Jun 27 '08 #1
Share this Question
Share on Google+
2 Replies

P: n/a
On Apr 21, 10:13 am, sophie_newbie <paulgeele...@gmail.comwrote:
Hi,

I'm using the python to set a cookie when a user logs in. Thing is it
doesn't seem to be setting properly in Internet Explorer. It works
grand in Firefox. Its basically:

c = Cookie.SimpleCookie()

c['username'] = uname

c['password'] = pword

print c

print pageContent

And thats it. I've a suspicion that it could be something to do with
the expiry time of the cookie. But I'm really not sure and don't
really know where to go with it. I've tried it on Internet Explorer on
2 machines and get the same problem.

Thanks for any help...
Did you make sure cookies are enabled in Internet Explorer?

You might also take a look at these pages:

http://www.voidspace.org.uk/python/a...ookielib.shtml
http://www.voidspace.org.uk/python/r...html#cookielib

They seem quite informative.

Mike
Jun 27 '08 #2

P: n/a
On Apr 21, 4:24 pm, Mike Driscoll <kyoso...@gmail.comwrote:
On Apr 21, 10:13 am, sophie_newbie <paulgeele...@gmail.comwrote:
Hi,
I'm using the python to set a cookie when a user logs in. Thing is it
doesn't seem to be setting properly in Internet Explorer. It works
grand in Firefox. Its basically:
c = Cookie.SimpleCookie()
c['username'] = uname
c['password'] = pword
print c
print pageContent
And thats it. I've a suspicion that it could be something to do with
the expiry time of the cookie. But I'm really not sure and don't
really know where to go with it. I've tried it on Internet Explorer on
2 machines and get the same problem.
Thanks for any help...

Did you make sure cookies are enabled in Internet Explorer?

You might also take a look at these pages:

http://www.voidspace.org.uk/python/a...html#cookielib

They seem quite informative.

Mike
Ya cookies are def enabled, will check that out thanks!
Jun 27 '08 #3

This discussion thread is closed

Replies have been disabled for this discussion.