468,321 Members | 1,848 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,321 developers. It's quick & easy.

Re: Module not found in script that was found in command-lineinterpreter. Possible Path issue?


On Apr 3, 2008, at 10:54 AM, Trent Mick wrote:
Jacob Davis wrote:
>I just installed the MySQLdb module and I have been able to get it
to run in my command line interpreter. I am running Mac Leopard,
and Python 2.5.
I have tested importing and actually connecting and using a MySQL
database, although it issues some warning:
SnakeBite:MySQL-python-1.2.2 Snake$ python
Python 2.5 (r25:51918, Sep 19 2006, 08:49:13) [GCC 4.0.1 (Apple
Computer, Inc. build 5341)] on darwin
Type "help", "copyright", "credits" or "license" for more
information.
>>>>import MySQLdb
/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/
site-packages/MySQL_python-1.2.2-py2.5-macosx-10.3-fat.egg/
_mysql.py:3: UserWarning: Module _mysql was already imported from

From that message it looks like this "python" is /usr/local/bin/
python (i.e. a separate installation than Apple's system python at /
usr/bin/python and /System/Library/Frameworks/Python.framework).

You can tell for sure by doing:

$ which python
>However, while writing a .py script (with Komodo Edit) I try to
simply import the module and the in-Komodo interpreter returns an
error:
Traceback (most recent call last):
File "/Users/Snake/Documents/NPS/Thesis/Source_Code/Genetics/
mysql_connect_test.py", line 11, in <module>
import MySQLdb
ImportError: No module named MySQLdb

I suspect that this is because your run of Komodo Edit doesn't have
"/usr/local/bin" on its PATH and is using "/usr/bin/python" instead
of the one you typically use on the command line.

You can configure Komodo to know about /usr/local/bin by adding a
"PATH" setting in the "Environment" prefs panel. Arguably Komodo
should just add /usr/local/bin to its runtime PATH by default, but
unfortunately it currently doesn't. Komodo doesn't pick up your
normal bash shell environment because of problems trying to get that
information in general.

Please let me know (or on the komodo-discuss list [^1] or Komodo bug
database [^2]) if you have any problems getting that going.

Cheers,
Trent

[1]: http://listserv.activestate.com/mail...Komodo-discuss
[2]: http://bugs.activestate.com/query.cgi?product=Komodo

--
Trent Mick
trentm at activestate.com
Thanks, that seems to have worked. I added "/usr/local/bin" to the
PATH in the preferences Environment panel in Komodo. Then in
preferences I went into the Python pane and changed my selected
interpreter from "/usr/bin/pythonw" to the now available "/usr/local/
bin/pythonw".

Thanks again,

Jake
Jun 27 '08 #1
0 769

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

4 posts views Thread by Steven | last post: by
2 posts views Thread by Marcus Schneider | last post: by
14 posts views Thread by DataSmash | last post: by
10 posts views Thread by Charles Russell | last post: by
5 posts views Thread by Stuart D. Gathman | last post: by
12 posts views Thread by reubendb | last post: by
4 posts views Thread by vincehofmeister | last post: by
1 post views Thread by howard w | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.