By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,965 Members | 1,450 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,965 IT Pros & Developers. It's quick & easy.

Stani's python ide 'spe' editor problem

P: n/a
Hi everyone,
The editor in spe on my system (win XP home sp2) does not do automatic
indentation..... I can't figure out why - it used to. I'm set up with
subversion so I have the very latest stuff from Stani. It's amazing how
not having automatic indentation can make working in the ide such a pain.

This has been going on for a while (like a few years), and the situation
is deteriorating - used to be that the indentation would work for a
while after restarting my system and then stop (until the next restart).
Now, with his latest stuff, it doesn't work at all.

Because it used to reset with a restart, it must have something to do
with a dll, like the scintilla editor dll? But that's kind of hard to
believe: why would the editor dll care about indentation?

Anyway, I am extremely frustrated. I've tried other ide's: pythonwin (I
found it inadequate for my purposes - why is a command line prompt
displayed in a dialog window?) - eclipse (editor is just ok, shell does
not have command history(!), and then *really* funky things started
happening that I could not explain and so had to stop using it) - idle
is good for small things and ok for larger projects but limited in general.

I really like spe and want to continue using it. Stani himself seems
pretty unreachable.

Does anyone have a clue for me about what the issue is? Is no one else
using this great ide? Or is no one else having this problem?

Thanks for any help.
-Rick King
Southfield MI
Apr 9 '08 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.