By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,097 Members | 1,529 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,097 IT Pros & Developers. It's quick & easy.

Can't get bsddb working on Solaris 8

P: n/a
I've been struggling with this all day. I am trying to get Python 2.5
running with the BerkeleyDB bindings provided by bsddb.

First, I downloaded the BerkeleyDB system (version 4.5) from
http://www.oracle.com/technology/pro...-db/index.html.

Then, I downloaded bsddb from http://pybsddb.sourceforge.net/ and
built it using my python 2.5 install with python2.5 setup.py build and
python2.5 setup.py install. During the install, the scripts explain
that they found the BerkeleyDB system version 4.5 right where I
installed it to.

I even tried rebuilding all of Python after my BerkeleyDB was set up.

My error persists:

File "/usr/local/lib/python2.5/bsddb/__init__.py", line 51, in
<module>
import _bsddb
ImportError: No module named _bsddb

This is a Solaris 8 machine (SunOS 5.8). I've added the library path (/
usr/local/BerkeleyDB.4.5/lib) to LD_LIBRARY_PATH before building.

I'm out of ideas. Any help? Thanks.
Mar 18 '08 #1
Share this Question
Share on Google+
1 Reply


P: n/a
I fixed it! I had omitted the cascade of exceptions, but the previous
one to the one shown is:

File "/usr/local/lib/python2.5/dbhash.py", line 5, in <module>
import bsddb

So I just went into dbhash.py and changed line 5 to import bsddb3 as
bsddb. Then everything started working as planned. Excellent! But
definitely a hack.
Mar 18 '08 #2

This discussion thread is closed

Replies have been disabled for this discussion.