471,336 Members | 1,428 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,336 software developers and data experts.

setdefaultencoding error

>>import sys
>>sys.setdefaultencoding(utf8)
Traceback (most recent call last):
File "<interactive input>", line 1, in <module>
AttributeError: 'module' object has no attribute 'setdefaultencoding'

but i find the attribute"setdefaultencoding" in python manuals

where is the error?
Dec 8 '07 #1
2 5472
On Dec 8, 8:36 pm, smalltalk <ttkk1...@gmail.comwrote:
>import sys
sys.setdefaultencoding(utf8)

Traceback (most recent call last):
File "<interactive input>", line 1, in <module>
AttributeError: 'module' object has no attribute 'setdefaultencoding'

but i find the attribute"setdefaultencoding" in python manuals

where is the error?
You need to do more than find an attribute in a manual, you need to
read what the manual says about that attribute.
Dec 8 '07 #2

thank you very much
I have solved
Dec 10 '07 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

5 posts views Thread by Askari | last post: by
5 posts views Thread by Tony Wright | last post: by
1 post views Thread by Aravind | last post: by
7 posts views Thread by p | last post: by
1 post views Thread by Robin Becker | last post: by
reply views Thread by rosydwin | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.