471,354 Members | 1,562 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,354 software developers and data experts.

problem with eric

Hello,
I have the following single line in my .py file:

from PyQt4 import QtCore, QtGui

if i run it from eric, i get the following error:

unhandled RuntimeError
"the PyQt4.QtCore and qt modules both wrap the QObject class"

i think that eric is probably trying to load both Qt3 and Qt4, but i don't
understand why (i'm explicitly mentioning PyQt4). How do i tell eric to use
just Qt4, and not Qt3?

ps: i have made both Qt and Qt4 Directory to contain /usr/share/qt4, in
preferences->qt. but that too does not help.
--
warm regards,
Pradnyesh Sawant
--
Computers are to make people happy, not people to make computers happy.
--Gerald Jay Sussman, MIT
Oct 19 '07 #1
0 904

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

9 posts views Thread by Eric | last post: by
6 posts views Thread by Eric Boutin | last post: by
25 posts views Thread by bruce.james.lee | last post: by
5 posts views Thread by Eric Twietmeyer | last post: by
7 posts views Thread by Jacob | last post: by
8 posts views Thread by Rob Edwards | last post: by
5 posts views Thread by Eric A. Johnson | last post: by
16 posts views Thread by Eric | last post: by
11 posts views Thread by aljaber | last post: by
18 posts views Thread by Eric | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.