By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
464,291 Members | 1,123 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 464,291 IT Pros & Developers. It's quick & easy.

IDLE path browser not recognizing my PYTHONPATH

P: n/a
Hi,

I set PYTHONPATH to /home/me/bin in bash.bashrc, however the IDLE path
browser is not recognizing this. Not sure why.

Grateful for any insight.

Best

Aug 14 '07 #1
Share this Question
Share on Google+
2 Replies

P: n/a
I set PYTHONPATH to /home/me/bin in bash.bashrc, however the IDLE path
browser is not recognizing this. Not sure why.

Grateful for any insight.
The file "bash.bashrc" has no relevance. If you meant to set the
variable every time you start bash, put it into ".bashrc", in your
home directory. If that still doesn't work, type "env" before starting
idle, and inspect its output.

Regards,
Martin
Aug 14 '07 #2

P: n/a
On Aug 14, 2:30 am, "Martin v. Lwis" <mar...@v.loewis.dewrote:
I set PYTHONPATH to /home/me/bin in bash.bashrc, however the IDLE path
browser is not recognizing this. Not sure why.
Grateful for any insight.

The file "bash.bashrc" has no relevance. If you meant to set the
variable every time you start bash, put it into ".bashrc", in your
home directory. If that still doesn't work, type "env" before starting
idle, and inspect its output.

Regards,
Martin
You also have to export, so to add to your existing PYTHONPATH, you
would add something like this to ~/.bashrc
export PYTHONPATH="${PYTHONPATH}:/home/me/bin/"

Aug 14 '07 #3

This discussion thread is closed

Replies have been disabled for this discussion.