By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,235 Members | 1,022 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,235 IT Pros & Developers. It's quick & easy.

Emacs + python.

P: n/a

Sorry to repeat, but I had to reinstall and lost all my news.

I am looking for pointers on using emacs with python. I use emacs v
22.0.91 (Ubuntu snapshot).

It comes with its own python mode.

The problem is that the debugger just hangs when I start it. The
interpreter runs fine. Any ideas?

What versions of python.el or python-mode.el or ..... are you using and
why?

Many thanks for any pointers.
Aug 6 '07 #1
Share this Question
Share on Google+
3 Replies


P: n/a
On Monday 06 August 2007, Hadron wrote:
Sorry to repeat, but I had to reinstall and lost all my news.
This list is archived at a number of publically accessible sites, for example:

http://mail.python.org/pipermail/python-list/
http://dir.gmane.org/gmane.comp.python.general
http://www.mail-archive.com/python-list%40python.org/
http://groups.google.com/group/comp.lang.python/topics

I assume you already asked and got an answer, so you should now be able to
find it.

--
Regards, Thomas Jollans
GPG key: 0xF421434B may be found on various keyservers, eg pgp.mit.edu
Hacker key <http://hackerkey.com/>:
v4sw6+8Yhw4/5ln3pr5Ock2ma2u7Lw2Nl7Di2e2t3/4TMb6HOPTen5/6g5OPa1XsMr9p-7/-6

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQBGtvmzJpinDvQhQ0sRAuKdAJ9wqlaPtlbJSJ7n3mtrpD erAcC6CwCfa6jG
5ToswaJ7DHntmzUfFrhzb0Y=
=gHBK
-----END PGP SIGNATURE-----

Aug 6 '07 #2

P: n/a
Hadron <ha*********@googlemail.comwrites:
Sorry to repeat, but I had to reinstall and lost all my news.

I am looking for pointers on using emacs with python. I use emacs v
22.0.91 (Ubuntu snapshot).

It comes with its own python mode.

The problem is that the debugger just hangs when I start it. The
interpreter runs fine. Any ideas?

What versions of python.el or python-mode.el or ..... are you using and
why?

Many thanks for any pointers.
I upgraded to emacs 23 from

http://peadrop.com/blog/2007/01/06/pretty-emacs/ and it works fine now.

Crosspost & Followup-To: gnu.emacs.help
Aug 6 '07 #3

P: n/a
Hadron <ha*********@googlemail.comwrites:
Sorry to repeat, but I had to reinstall and lost all my news.
Fortunately, there's no need to repeat, because the forum is archived
both as a Usenet newsgroup and a mailing list.

<URL:http://groups.google.com/group/comp.lang.python/>
<URL:http://mail.python.org/pipermail/python-list/>

--
\ "What you have become is the price you paid to get what you |
`\ used to want." -- Mignon McLaughlin |
_o__) |
Ben Finney
Aug 6 '07 #4

This discussion thread is closed

Replies have been disabled for this discussion.