471,337 Members | 1,379 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,337 software developers and data experts.

Problem with windows NT directories

Hi, I've got a problem, when im examin windows NT directories.
I've written a program that checks if certain directories exist. Im using "os.popen('dir \/B "\\\\' + computer name + \c$\\program files\argument"').readlines()!=[]" to check if the directory is empty or not. It works fine on windows XP machines and 2003 servers, but i fails on NT maschines, saying that the directory exists eventhough it doesnt.....
Any suggestions what im doing wrong??
Jul 30 '07 #1
1 918
Hi, I've got a problem, when im examin windows NT directories.
I've written a program that checks if certain directories exist. Im using "os.popen('dir \/B "\\\\' + computer name + \c$\\program files\argument"').readlines()!=[]" to check if the directory is empty or not. It works fine on windows XP machines and 2003 servers, but i fails on NT maschines, saying that the directory exists eventhough it doesnt.....
Any suggestions what im doing wrong??
Nevermind, I've solved the problem.
Aug 1 '07 #2

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

reply views Thread by Chann Becker | last post: by
2 posts views Thread by flamesrock | last post: by
4 posts views Thread by Stimp | last post: by
reply views Thread by rosydwin | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.