471,330 Members | 1,490 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,330 software developers and data experts.

Freeze and problem with shared libraries

I am trying to use freeze to create a single binary executable for one
of my program. When I run freeze, it runs fine with the following
modules. These modules are available in the dyn-load directory and I
can import them from the python interpreter.
Warning: unknown modules remain: _bisect _heapq _locale _random
_socket
Make also runs fine, but when I run the program on another machine, it
compiles saying could not import these modules. Any idea how to get
this working...

Or can I have a directory of shared libs in a directory and do,
import imp
imp.load_dynamic()
This will not be as good as having a single binary file, but will work
I guess...

Thanks.
-
Suresh

Jul 3 '07 #1
0 990

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

11 posts views Thread by Timothy Shih | last post: by
2 posts views Thread by mrstephengross | last post: by
2 posts views Thread by kristian.hermansen | last post: by
1 post views Thread by w chun | last post: by
1 post views Thread by jmalone | last post: by
2 posts views Thread by Flyzone | last post: by
6 posts views Thread by Mike Kent | last post: by
10 posts views Thread by Unknown Soldier | last post: by
reply views Thread by rosydwin | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.