471,317 Members | 1,514 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,317 software developers and data experts.

amara bugs

I tried to install amara according to the recommendations on this
list. There were evidently compilation errors. The results are below

Also the quick reference gives 404 not found errors

Thanks

$ sudo easy_install amara

Searching for amara
Best match: Amara 1.2.0.2
Processing Amara-1.2.0.2-py2.4.egg
Amara 1.2.0.2 is already the active version in easy-install.pth
Installing trimxml script to /usr/bin
Installing flextyper script to /usr/bin
Installing scimitar script to /usr/bin

Using /usr/lib/python2.4/site-packages/Amara-1.2.0.2-py2.4.egg
Processing dependencies for amara
Searching for 4Suite-XML>=1.0.2
Reading http://www.python.org/pypi/4Suite-XML/
Reading http://4suite.org/
Reading http://www.python.org/pypi/4Suite-XML/1.0.2
Best match: 4Suite-XML 1.0.2
Downloading http://cheeseshop.python.org/package...af71d2af0a539a
Processing 4Suite-XML-1.0.2.zip
Running 4Suite-XML-1.0.2/setup.py -q bdist_egg --dist-dir
/tmp/easy_install-w9816x/4Suite-XML-1.0.2/egg-dist-tmp-xg9AOi
Ft/Lib/src/number.c:7:20: error: Python.h: No such file or directory
Ft/Lib/src/number.c:10: error: expected '=', ',', ';', 'asm' or
'__attribute__' before '*' token
Ft/Lib/src/number.c:14: error: expected '=', ',', ';', 'asm' or
'__attribute__' before '*' token
Ft/Lib/src/number.c:36: error: expected '=', ',', ';', 'asm' or
'__attribute__' before '*' token
Ft/Lib/src/number.c:57: error: expected '=', ',', ';', 'asm' or
'__attribute__' before '*' token
Ft/Lib/src/number.c:75: error: expected '=', ',', ';', 'asm' or
'__attribute__' before 'numberMethods'
Ft/Lib/src/number.c:82: warning: return type defaults to 'int'
Ft/Lib/src/number.c: In function 'DL_EXPORT':
Ft/Lib/src/number.c:82: error: expected declaration specifiers before
'initnumber'
Ft/Lib/src/number.c:99: error: expected '{' at end of input
error: Setup script exited with error: command 'gcc' failed with exit status 1
Jun 25 '07 #1
0 954

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

83 posts views Thread by kartik | last post: by
reply views Thread by Jay | last post: by
3 posts views Thread by Doru-Catalin Togea | last post: by
reply views Thread by Doru-Catalin Togea | last post: by
2 posts views Thread by TheSteph | last post: by
19 posts views Thread by Alan Silver | last post: by
2 posts views Thread by mirandacascade | last post: by
5 posts views Thread by AdSR | last post: by
reply views Thread by rosydwin | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.