473,242 Members | 1,466 Online
Bytes | Software Development & Data Engineering Community
Post Job

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 473,242 software developers and data experts.

Issue with wxPython compile on linux (stc.h doesn't get installed)

hi - I've been trying to get wxPython 2.8.4.0 installed on my Linux machine by following the instructions given by the BUILD document at the wxPython download site. I've been able to do the wxWidget configure with no problems and was able to run make on wxWidgets, contrib/src/gizmos, and contrib/src/stc. I had no problem running make install and have ran a program (forgot its name) that the make install suggests that I run to (reset?) the shared library definitions. I've set the environment variables as the BUILD document suggests.

Then I went on to run: python2.5 setup.py build_ext --inplace --debug and it chugs along for a while before stopping and returning an error in which stc.h cannot be found. A little googling around led me to find out that doing make /contrib/src/stc should have installed stc.h at the wx install directory (in my case, /opt/wx/2.8/include/wx-2.8/wx/stc). I do not have stc.h installed at all at that directory. I haven't been able to figure out how to get that accomplished - can anyone offer some assistance?

thanks
Jun 9 '07 #1
0 1139

Sign in to post your reply or Sign up for a free account.

Similar topics

3
by: Logan | last post by:
I asked a similar question already in the wxPython mailing list, but did not get an answer up to now: 1.) When using a TextCtrl with styles (color etc.) in wxPython, is it then possible to get a...
5
by: JamesW | last post by:
Dear All, I need to install wxPython to run some programs that interest me. I have had numerous problems, probably due to knowing little about the packages and python, and taking the computer...
13
by: Peter Maas | last post by:
Recently I replaced Win2k with Linux on my desktop computer. Using mostly multi-platform software I thought this would be easy. It was not as easy as expected getting wxPython to work. There seemed...
1
by: timothy.williams | last post by:
I'm trying to install wxPython 2.5.3.1 using Python 2.3.2 on a Fedora 2 machine. I have python in a non-standard place, but I'm using --prefix with the configure script to point to where I have...
2
by: Stephane Roy | last post by:
Hi, Did someone installed and used successfully drPython on Cygwin? The installation requires wxpython. I tried many different alternatives (source, binary, etc) but so far the best I get is...
0
by: DarkBlue | last post by:
Trying to install wxPython on Suse10.1 64 with gcc4.1.0 and get wxPython-src-2.6.3.2/wxPython # python setup.py install Found wx-config: /usr/local/bin/wx-config Using flags: --toolkit=gtk2...
3
by: SMALLp | last post by:
Hy. I'm new in linux (Ubuntu 7.10) as well as in python. I installed IDLE, and i installed package python-wxgtkX. I start IDLE and when i want co compile my aplication all windows close. Also when...
0
by: Gabriel Genellina | last post by:
En Sun, 28 Sep 2008 19:25:30 -0300, Stef Mientki <stef.mientki@gmail.com> escribió: wx is a package. Modules within the package are not, by default, attributes of the package - unless they're...
2
by: timw.google | last post by:
The subject line says it all. Is there a way to install wxPython on a Windows machine without admin privs? I love the way python doesn't need admin to install locally, and I'd like to try wxPython...
2
isladogs
by: isladogs | last post by:
The next Access Europe meeting will be on Wednesday 7 Feb 2024 starting at 18:00 UK time (6PM UTC) and finishing at about 19:30 (7.30PM). In this month's session, the creator of the excellent VBE...
0
by: fareedcanada | last post by:
Hello I am trying to split number on their count. suppose i have 121314151617 (12cnt) then number should be split like 12,13,14,15,16,17 and if 11314151617 (11cnt) then should be split like...
0
by: stefan129 | last post by:
Hey forum members, I'm exploring options for SSL certificates for multiple domains. Has anyone had experience with multi-domain SSL certificates? Any recommendations on reliable providers or specific...
0
by: MeoLessi9 | last post by:
I have VirtualBox installed on Windows 11 and now I would like to install Kali on a virtual machine. However, on the official website, I see two options: "Installer images" and "Virtual machines"....
0
by: DolphinDB | last post by:
The formulas of 101 quantitative trading alphas used by WorldQuant were presented in the paper 101 Formulaic Alphas. However, some formulas are complex, leading to challenges in calculation. Take...
0
by: DolphinDB | last post by:
Tired of spending countless mintues downsampling your data? Look no further! In this article, you’ll learn how to efficiently downsample 6.48 billion high-frequency records to 61 million...
0
by: Aftab Ahmad | last post by:
Hello Experts! I have written a code in MS Access for a cmd called "WhatsApp Message" to open WhatsApp using that very code but the problem is that it gives a popup message everytime I clicked on...
0
by: Aftab Ahmad | last post by:
So, I have written a code for a cmd called "Send WhatsApp Message" to open and send WhatsApp messaage. The code is given below. Dim IE As Object Set IE =...
0
by: ryjfgjl | last post by:
ExcelToDatabase: batch import excel into database automatically...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.