By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,235 Members | 1,011 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,235 IT Pros & Developers. It's quick & easy.

anyone has experience on cross-compile python 2.5.1?

P: n/a
i have a development board based on s3c2410 arm cpu. and i want to
port python on it.
after googling some threads, i successfully cross compiled python.
but i still encountered a weird issue that when i ran
/lib/python2.5/test/testall.py,
the process stuck at test_asynchat.py, i located the stuck point here:

def test_numeric_terminator(self):
# Try reading a fixed number of bytes
s = echo_server()
s.start()         # <----- stuck here !!!
time.sleep(1) # Give server time to initialize
c = echo_client(6L)
c.push("hello ")
c.push("world\n")
asyncore.loop()
s.join()
but the weirdest thing is, if i run python test_asynchat.py directly,
everything is ok.
anybody could help me?

thanks in advance.

ps, my linux box is an ubuntu 6.10.

--
Best Regards,
Leo Jay
Apr 30 '07 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.