467,077 Members | 980 Online
Bytes | Developer Community
Ask Question

Home New Posts Topics Members FAQ

Post your question to a community of 467,077 developers. It's quick & easy.

Problem installing Python 2.5

I was trying to install Python 2.5 compiling from sources. I used:
../compile
It run OK.
Then:
make altintall
After a lot of output, got this:
Listing /usr/local/lib/python2.5/xml/sax ...
Compiling /usr/local/lib/python2.5/xml/sax/__init__.py ...
Compiling /usr/local/lib/python2.5/xml/sax/_exceptions.py ...
Compiling /usr/local/lib/python2.5/xml/sax/expatreader.py ...
Compiling /usr/local/lib/python2.5/xml/sax/handler.py ...
Compiling /usr/local/lib/python2.5/xml/sax/saxutils.py ...
Compiling /usr/local/lib/python2.5/xml/sax/xmlreader.py ...
Compiling /usr/local/lib/python2.5/xmllib.py ...
Compiling /usr/local/lib/python2.5/xmlrpclib.py ...
Compiling /usr/local/lib/python2.5/zipfile.py ...
make: *** [libinstall] Error 1

It seems I am not the only one with this error:
http://www.thescripts.com/forum/thread613458.html
http://www.megasolutions.net/python/...up)-22624.aspx
http://ubuntuforums.org/showthread.php?p=1912370

System: Freespire 1.0.13 (based on Debian).
Apr 3 '07 #1
  • viewed: 3332
Share:
3 Replies
Dnia Tue, 3 Apr 2007 11:52:55 -0300, Sebastian Bassi napisa³(a):
I was trying to install Python 2.5 compiling from sources. I used:
./compile
It run OK.
Then:
make altintall
After a lot of output, got this:
Listing /usr/local/lib/python2.5/xml/sax ...
Compiling /usr/local/lib/python2.5/xml/sax/__init__.py ...
Compiling /usr/local/lib/python2.5/xml/sax/_exceptions.py ...
Compiling /usr/local/lib/python2.5/xml/sax/expatreader.py ...
Compiling /usr/local/lib/python2.5/xml/sax/handler.py ...
Compiling /usr/local/lib/python2.5/xml/sax/saxutils.py ...
Compiling /usr/local/lib/python2.5/xml/sax/xmlreader.py ...
Compiling /usr/local/lib/python2.5/xmllib.py ...
Compiling /usr/local/lib/python2.5/xmlrpclib.py ...
Compiling /usr/local/lib/python2.5/zipfile.py ...
make: *** [libinstall] Error 1

It seems I am not the only one with this error:
http://www.thescripts.com/forum/thread613458.html
http://www.megasolutions.net/python/...up)-22624.aspx
http://ubuntuforums.org/showthread.php?p=1912370

System: Freespire 1.0.13 (based on Debian).
After executing

./configure

you have to edito

Modules/Setup

file and uncomment the following line:

#zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz

Then continue with normal make; make install.

--
Jaroslaw Zabiello
http://blog.zabiello.com
Apr 3 '07 #2
On 4/3/07, Jaroslaw Zabiello <hi**********@gmail.comwrote:
After executing
./configure
you have to edito
Modules/Setup
file and uncomment the following line:
#zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz
Then continue with normal make; make install.
Thank you. I already did this:
make -i altinstall
and then:
make altinstall

And added a comment in bug#1669349
Best,
SB.
Apr 3 '07 #3
After a lot of output, got this:

You will need to check this output line-for-line to see
why it fails.

Regards,
Martin
Apr 4 '07 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by Rami A. Kishek | last post: by
2 posts views Thread by Will McGugan | last post: by
5 posts views Thread by Christian Stapfer | last post: by
4 posts views Thread by Nico Grubert | last post: by
5 posts views Thread by Cappy2112 | last post: by
2 posts views Thread by jiang.haiyun@gmail.com | last post: by
1 post views Thread by Dogzilla1000@gmail.com | last post: by
reply views Thread by Gabriel Genellina | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.