By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
446,361 Members | 1,677 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 446,361 IT Pros & Developers. It's quick & easy.

IDLE & MySQLdb import error

P: n/a
I installed python 2.5 and used the win package for installing MySQLdb. (Iam running Windows XP)
Everything works as expected using python directly (Windows command shell) but using IDLE gives the import error below.
Same error with PythonWin as my IDE and everything works using python 2.4-- with IDLE and without, mySQLdb is loaded with out error.
Below is the IDLEscreen capture

Python 2.5 (r25:51908, Sep 19 2006, 09:52:17) [MSC v.1310 32 bit (Intel)] on win32
Type "copyright", "credits" or "license()" for more information.
************************************************** **************
Personal firewall software may warn about the connection IDLE
makes to its subprocess using this computer's internal loopback
interface. This connection is not visible on any external
interface and no data is sent to or received from the Internet.
************************************************** **************

IDLE 1.2
>>import MySQLdb
Traceback (most recent call last):
File "<pyshell#1>", line 1, in <module>
import MySQLdb
File "C:\Python25\lib\site-packages\MySQLdb\__init__.py", line 19, in <module>
import _mysql
ImportError: DLL load failed: The specified procedure could not be found.
>>>
It seems that when using IDLE the _mysql package cannot be found although the path is the same as non-IDLE
python and help('modules') shows _mysql is an available.

Is this an IDLE or MySQLdb bug or some incorrect settign on my side

__________________________________________________ __________________________________
Looking for earth-friendly autos?
Browse Top Cars by "Green Rating" at Yahoo! Autos'Green Center.
http://autos.yahoo.com/green_center/
Mar 4 '07 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.