468,133 Members | 1,155 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,133 developers. It's quick & easy.

"unknown encoding: string-escape" in frozen Python

I'm using FreezePython on a Python program that uses wxPython and subprocess.
The result almost works, but it always hits this bug:

File "velauncher.py", line 847, in Launch
File "python/velLaunchCode.py", line 61, in __init__
File "python/velLaunchCode.py", line 143, in Unix
File "python/subprocess.py", line 599, in __init__
File "python/subprocess.py", line 1031, in _execute_child
File "/usr/lib/python2.3/pickle.py", line 1394, in loads
return Unpickler(file).load()
File "/usr/lib/python2.3/pickle.py", line 872, in load
dispatch[key](self)
File "/usr/lib/python2.3/pickle.py", line 985, in load_string
self.append(rep.decode("string-escape"))
LookupError: unknown encoding: string-escape

I tried adding --include-modules=encodings to the arguments, but I'm still
getting the string-escape error. How can I include the encoding in the freeze?

I'm using Python2.3 and the downloadable version of subprocess.py for Python2.3
on Redhat.

-Jeff Groves
Mar 3 '07 #1
0 1843

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

3 posts views Thread by Philipp Lenssen | last post: by
2 posts views Thread by Gustaf Liljegren | last post: by
reply views Thread by Robert | last post: by
3 posts views Thread by Marcus | last post: by
9 posts views Thread by Klaus Johannes Rusch | last post: by
6 posts views Thread by Sile | last post: by
4 posts views Thread by =?Utf-8?B?RGF2aWQgVGhpZWxlbg==?= | last post: by
27 posts views Thread by didacticone | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.