471,119 Members | 1,377 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,119 software developers and data experts.

strange problem using modules from my own package.

hello all,
I found a very strange kind of behaviour in python with my own package.
I created a package in which there were 4 modules and one __init__.py file
I created the entire project in eclipse (pydev).
it works fine there with the ide.
but now when I try running the code without eclipse, that is when I
run the individual .py file from a command promt it gives me error.
for example I have mainwindow.py, customer.py, stock.py and of course
__init__p.py in my package
the app is in wxpython which is not important in the context of this problem.
never the less I go in the directory called pbcf which is the name of
my package
there I have all the above mentioned files and the mainwindow.py file
is the one I run for testing all the menus.
but here the moment I run the file, it starts giving me an error
saying pbcf is not a module.
I find that the same code runs without any problem in eclipse.
in mainwindow.py I have from pbcf import * and in __init__.py I have
of course included MySQLdb and wx
and in __init__.py I have a connection object called CONCSS.
now when I have all the imports in mainwindow, it does work in eclipse
but does not on a normal command prompt.
why is this?
regards.
Krishnakant.
Feb 8 '07 #1
0 880

This discussion thread is closed

Replies have been disabled for this discussion.

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.