By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,965 Members | 1,962 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,965 IT Pros & Developers. It's quick & easy.

CORBA: Fnorb Problems

P: n/a
Hi,

I have installed Fnorb and everything seems to have gone ok. However I
keep getting the error message below. This is despite the fact that the
MS CL c++ preprocessor seems to be in PATH. I can type "cl" and
although I get nothing back in the DOS window, there is also no error
message.

Traceback (most recent call last):
File "C:\Python24\Lib\site-packages\Fnorb\script\cpp.py", line 53, in
-toplevel-
raise "No C/C++ pre-processor found in your PATH!"
No C/C++ pre-processor found in your PATH!

On seeing what information is returned the variables which are
searching for the presence of CL in PATH come back with nothing.

System: Windows XP, Python 2.4, Most recent version of Fnorb 1.3.

Any pointers are welcome. Thanks in advance.
Best,

rod

Nov 13 '06 #1
Share this Question
Share on Google+
6 Replies


P: n/a
rodmc wrote:
Hi,

I have installed Fnorb and everything seems to have gone ok. However I
keep getting the error message below. This is despite the fact that the
MS CL c++ preprocessor seems to be in PATH. I can type "cl" and
although I get nothing back in the DOS window, there is also no error
message.

Traceback (most recent call last):
File "C:\Python24\Lib\site-packages\Fnorb\script\cpp.py", line 53, in
-toplevel-
raise "No C/C++ pre-processor found in your PATH!"
No C/C++ pre-processor found in your PATH!

On seeing what information is returned the variables which are
searching for the presence of CL in PATH come back with nothing.

System: Windows XP, Python 2.4, Most recent version of Fnorb 1.3.

Any pointers are welcome. Thanks in advance.
I used omniorb, and have been very satisfied with it. You might consider
switching.

Diez
Nov 13 '06 #2

P: n/a
>
I used omniorb, and have been very satisfied with it. You might consider
switching.

Diez
Thanks, I have just downloaded that plus omniORBpy as well. I have the
binary version of omniORB but need to build omniORBpy, from what I can
see the build process is aimed at GCC and not VC++. Anyway I will try
to figure it out.

Best,

rod

Nov 13 '06 #3

P: n/a
On Mon, 13 Nov 2006 16:16:37 +0100, rodmc <us***************@yahoo.co.uk>
wrote:
Hi,

I have installed Fnorb and everything seems to have gone ok. However I
keep getting the error message below. This is despite the fact that the
MS CL c++ preprocessor seems to be in PATH. I can type "cl" and
although I get nothing back in the DOS window, there is also no error
message.

Traceback (most recent call last):
File "C:\Python24\Lib\site-packages\Fnorb\script\cpp.py", line 53, in
-toplevel-
raise "No C/C++ pre-processor found in your PATH!"
No C/C++ pre-processor found in your PATH!
You don't say *when* this error occurs, i.e. what is the command that
returns the exception. Assuming it's when you try to compile an IDL file
with fnidl, just try:
fnidl --internal-cpp ...

HTH
--
python -c "print ''.join([chr(154 - ord(c)) for c in
'U(17zX(%,5.zmz5(17l8(%,5.Z*(93-965$l7+-'])"
Nov 13 '06 #4

P: n/a
Traceback (most recent call last):
File "C:\Python24\Lib\site-packages\Fnorb\script\cpp.py", line 53, in
-toplevel-
raise "No C/C++ pre-processor found in your PATH!"
No C/C++ pre-processor found in your PATH!

You don't say *when* this error occurs, i.e. what is the command that
returns the exception. Assuming it's when you try to compile an IDL file
with fnidl, just try:
fnidl --internal-cpp ...
Sorry you are right I did not say, but you guessed correctly. However
even when I try your advice I still receive the same error.

Best,

rod

Nov 14 '06 #5

P: n/a
On Tue, 14 Nov 2006 13:13:42 +0100, rodmc <us***************@yahoo.co.uk
wrote:
>
Traceback (most recent call last):
File "C:\Python24\Lib\site-packages\Fnorb\script\cpp.py", line 53,
in
-toplevel-
raise "No C/C++ pre-processor found in your PATH!"
No C/C++ pre-processor found in your PATH!

You don't say *when* this error occurs, i.e. what is the command that
returns the exception. Assuming it's when you try to compile an IDL file
with fnidl, just try:
fnidl --internal-cpp ...

Sorry you are right I did not say, but you guessed correctly. However
even when I try your advice I still receive the same error.
I took a look at the Fnorb sources and it appears you're right: even if
the --internal-cpp flag is used, fnidl still tests if the MS compiler
exists and breaks if it can't be called or if it doesn't return what fnidl
expects. The actual test is whether the cl output contains the string
"/link", whatever the character case. So as you said in your original post
that cl can be run, but doesn't print anything, this seems to be the
problem.

What you can do is the following: go to Fnorb's source directory and edit
scripts/cpp.py; on line 53, replace the "raise ..." by:
COMMAND = None
with the same indent.

Then run fnidl again with the --internal-cpp flag. This should work and
produce the expected files.

Note that this is a dirty hack: if you forget to specify the
--internal-cpp flag, you'll get a nasty traceback. But it should work in
your case.

HTH
--
python -c "print ''.join([chr(154 - ord(c)) for c in
'U(17zX(%,5.zmz5(17l8(%,5.Z*(93-965$l7+-'])"
Nov 14 '06 #6

P: n/a
Thanks the fix you provided me with workds perfectly.

Best,

rod

Nov 15 '06 #7

This discussion thread is closed

Replies have been disabled for this discussion.