469,282 Members | 1,950 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,282 developers. It's quick & easy.

os x make install dies when compiling zipfile.py on 2.5 and 2.4.4

I've tried both Python 2.4.4 and Python 2.5. I'm trying to build from
source and install under a local directory Swarm since OpenSwarm
requires builds of Postgres and Python under it's control.

Ok, so I did

../configure --prefix=/Users/tbrannon/Documents/Python/Swarm/Python-2.5

but during make install I get this:

Compiling
/Users/tbrannon/Documents/Python/Swarm/Python-2.5/lib/python2.5/xmlrpclib.py
....
Compiling
/Users/tbrannon/Documents/Python/Swarm/Python-2.5/lib/python2.5/zipfile.py
....
make: *** [libinstall] Error 1
<!-- ~/Downloads/Python-2.5 tbrannon -->

and the same thing happens for Python 2.4.4 leaving me without a
platform-depedent install directory in my build.. any ideas?

Nov 6 '06 #1
2 2123
I've experienced the exact same with 2.4.4.

uname -a on the machine I built it on (SunOS 5.7, binaries should be
forwards-compatible with 5.7-5.10):
SunOS hostname-here 5.7 Generic_106541-19 sun4u sparc SUNW,Ultra-4

And the machine on which it was being installed (because it has write
access to the NFS mount I want it installed on):
SunOS hostname-here 5.10 Generic_118822-25 sun4u sparc
SUNW,Sun-Fire-V210

I only *just* hit this and haven't dug further for a solution. If
anyone knows about this please respond, otherwise I'll post any
progress I make.

On Nov 6, 4:20 pm, "metaperl" <metap...@gmail.comwrote:
I've tried both Python 2.4.4 and Python 2.5. I'm trying to build from
source and install under a local directory Swarm since OpenSwarm
requires builds of Postgres and Python under it's control.

Ok, so I did

./configure --prefix=/Users/tbrannon/Documents/Python/Swarm/Python-2.5

but during make install I get this:

Compiling
/Users/tbrannon/Documents/Python/Swarm/Python-2.5/lib/python2.5/xmlrpclib.py
...
Compiling
/Users/tbrannon/Documents/Python/Swarm/Python-2.5/lib/python2.5/zipfile.py
...
make: *** [libinstall] Error 1
<!-- ~/Downloads/Python-2.5 tbrannon -->

and the same thing happens for Python 2.4.4 leaving me without a
platform-depedent install directory in my build.. any ideas?
Nov 20 '06 #2
Sorry about the top-post earlier.

I just tested installing 2.4.4 on the same machine that built it--- it
ran without a complaint. The line that follows the "Compiling
zipfile.py" line (possibly the one that is failing for us) is as
follows:

Compiling /Home/admin/sayotte/python-test/lib/python2.4/zipfile.py ...
PYTHONPATH=/Home/admin/sayotte/python-test/lib/python2.4 \
./python -Wi -t
/Home/admin/sayotte/python-test/lib/python2.4/compileall.py \
-d /Home/admin/sayotte/python-test/lib/python2.4/site-packages
-f \
-x badsyntax
/Home/admin/sayotte/python-test/lib/python2.4/site-packages
Listing /Home/admin/sayotte/python-test/lib/python2.4/site-packages ...

Were you by chance also executing the build and install steps on
different platforms?

Nov 20 '06 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by Chris Hadley | last post: by
reply views Thread by Craig D | last post: by
1 post views Thread by Waitman Gobble | last post: by
reply views Thread by Schnizalfritz | last post: by
2 posts views Thread by fartknuckle | last post: by
3 posts views Thread by towers | last post: by
1 post views Thread by John Machin | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
reply views Thread by suresh191 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.