By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,836 Members | 1,983 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,836 IT Pros & Developers. It's quick & easy.

pyPgSQL / trac issues

P: n/a
Hey guys,

Has anyone seen this error when installing trac? The problem seems
related to pyPgSQL, which is installed. (Although I had to go in and
add some headers to make it work)

Templates directory [/usr/local/share/trac/templates]>

Creating and Initializing Project
Failed to create environment.
/usr/local/lib/python2.4/site-packages/pyPgSQL/libpq/libpqmodule.so:
undefined symbol: lo_export
Traceback (most recent call last):
File "/usr/local/lib/python2.4/site-packages/trac/scripts/admin.py",
line 139, in env_create
self.__env = Environment(self.envname, create=True, db_str=db_str)
File "/usr/local/lib/python2.4/site-packages/trac/env.py", line 79,
in __init__
self.create(db_str)
File "/usr/local/lib/python2.4/site-packages/trac/env.py", line 197,
in create
db.init_db(self.path, db_str)
File "/usr/local/lib/python2.4/site-packages/trac/db.py", line 442,
in init_db
cls.init_db(**args)
File "/usr/local/lib/python2.4/site-packages/trac/db.py", line 408,
in init_db
self = cls(**args)
File "/usr/local/lib/python2.4/site-packages/trac/db.py", line 376,
in __init__
from pyPgSQL import PgSQL
File "/usr/local/lib/python2.4/site-packages/pyPgSQL/PgSQL.py", line
449, in ?
from libpq import *
File
"/usr/local/lib/python2.4/site-packages/pyPgSQL/libpq/__init__.py",
line 23, in ?
from libpq import *
ImportError:
/usr/local/lib/python2.4/site-packages/pyPgSQL/libpq/libpqmodule.so:
undefined symbol: lo_export
Failed to initialize environment. 1
Traceback (most recent call last):
File "/usr/local/lib/python2.4/site-packages/trac/scripts/admin.py",
line 594, in do_initenv
self.env_create(db_str)
File "/usr/local/lib/python2.4/site-packages/trac/scripts/admin.py",
line 144, in env_create
sys.exit(1)
SystemExit: 1

Sep 5 '06 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.