By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,812 Members | 875 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,812 IT Pros & Developers. It's quick & easy.

using Jython in Websphere 6.0

P: n/a
Used the following command to extract correct commandLine arguments to
Automate deployment:

AdminApp.installInteractive('z:/Builds_test/sgs/sgs-procDist.ear')

Got the following Args to use for deployment..

install 'z:/Builds_test/sgs/sgs-procDist.ear' '[ -preCompileJSPs
-installed.ear.destination
d:/WebSphere/AppServer/profiles/profileStandAlone/installedApps/TESTND1Network
-distributeApp -nouseMetaDataFromBinary -nodeployejb -appname
SGSProcedure -createMBeansForResources -noreloadEnabled -nodeployws
-validateinstall warn -noprocessEmbeddedConfig -MapModulesToServers
[["SGS Wizard" sgs-procDist.war,WEB-INF/web.xml
WebSphere:cell=TESTND1Network,node=IIS,server=webs erver+WebSphere:cell=TESTND1Network,cluster=SGSPro cedure]]
-MapWebModToVH [["SGS Wizard" sgs-procDist.war,WEB-INF/web.xml
default_host]]]'
When trying to execute command below via "wsadmin -lang jython"
commanfpromt I got the error below..??? Can anyone HELP ??

Traceback (innermost last):
(no code object) at line 0
File "<input>", line 1
AdminApp.install 'z:/Builds_test/sgs/sgs-procDist.ear' '[
-preCompileJS
Ps -installed.ear.destination
d:/WebSphere/AppServer/profiles/profileStandAlone/
installedApps/TESTND1Network -distributeApp -nouseMetaDataFromBinary
-nodeployej
b -appname SGSProcedure -createMBeansForResources -noreloadEnabled
-nodeployws -
validateinstall warn -noprocessEmbeddedConfig -MapModulesToServers
[["SGS Wizard
" sgs-procDist.war,WEB-INF/web.xml
WebSphere:cell=TESTND1Network,node=IIS,server
=webserver+WebSphere:cell=TESTND1Network,cluster=S GSProcedure]]]'
^
SyntaxError: invalid syntax
wsadmin>

Jul 24 '06 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.