470,614 Members | 1,396 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,614 developers. It's quick & easy.

wxPython problems with Fedora Core 5

Hi all,

I'm trying to use wxPython from a fairly new installation of Fedora
Core 5. I installed wxPython using yum -y install wxPython and that all
seemed to work fine. However, when I run Python and do this:

import wx

I get this:

Traceback (most recent call last):
File "<stdin>", line 1, in ?
File "/usr/lib/python2.4/site-packages/wx/__init__.py", line 45, in ?
from wxPython import wx
File "/usr/lib/python2.4/site-packages/wxPython/__init__.py", line
20, in ?
import wxc
ImportError: /usr/lib/libwx_gtk2-2.4.so.0: undefined symbol:
pango_x_get_context

Anyone have any ideas what's going on and what I can do to fix this?

Thanks in advance,
Doug

Jun 2 '06 #1
3 1616

writeson wrote:
Hi all,

I'm trying to use wxPython from a fairly new installation of Fedora
Core 5. I installed wxPython using yum -y install wxPython and that all
seemed to work fine. However, when I run Python and do this:

import wx

I get this:

Traceback (most recent call last):
File "<stdin>", line 1, in ?
File "/usr/lib/python2.4/site-packages/wx/__init__.py", line 45, in ?
from wxPython import wx
File "/usr/lib/python2.4/site-packages/wxPython/__init__.py", line
20, in ?
import wxc
ImportError: /usr/lib/libwx_gtk2-2.4.so.0: undefined symbol:
pango_x_get_context

Anyone have any ideas what's going on and what I can do to fix this?

Thanks in advance,
Doug


Check the FC5 Forums, I think the basic answer was to remove the python
"compat"
rpms.

Jerry

Jun 2 '06 #2

writeson wrote:
Hi all,

I'm trying to use wxPython from a fairly new installation of Fedora
Core 5. I installed wxPython using yum -y install wxPython and that all
seemed to work fine. However, when I run Python and do this:

import wx

I get this:

Traceback (most recent call last):
File "<stdin>", line 1, in ?
File "/usr/lib/python2.4/site-packages/wx/__init__.py", line 45, in ?
from wxPython import wx
File "/usr/lib/python2.4/site-packages/wxPython/__init__.py", line
20, in ?
import wxc
ImportError: /usr/lib/libwx_gtk2-2.4.so.0: undefined symbol:
pango_x_get_context

Anyone have any ideas what's going on and what I can do to fix this?

Thanks in advance,
Doug


Here is a link to a message in the wxpython-users mailing list archive,
which apparently gives the solution to your problem.

http://tinyurl.com/gf276

I cannot vouch for it. I installed wxPython on FC5 without any
problems, using the FC4 binary rpm's from wxPython.org.

Hope it works for you.

Frank Millman

Jun 3 '06 #3
Frank,

Thanks for the link, that solved the problem for me with FC5! That was
a great help to me!

Doug

Jun 15 '06 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

6 posts views Thread by Batista, Facundo | last post: by
1 post views Thread by James Stroud | last post: by
5 posts views Thread by linuxfreak | last post: by
1 post views Thread by contact | last post: by
4 posts views Thread by scottholdensmith | last post: by
2 posts views Thread by stevenq1967 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.