469,622 Members | 1,462 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,622 developers. It's quick & easy.

PyTables Error: ...import *

Hello,

I am using an XP box and Python 2.3 (Enthought Edition). I am getting
the same error with both of the .exe's listed on sourceforge:

tables-1.0.win32-py2.3.exe
tables-1.0.LB.win32-py2.3.exe

Note that the installation seems to go fine. Although, when I run the
test_all.py file it seems to fall over due to references to numarray; I
am using Numeric.

I am trying to follow the PyTables User Guide:

http://pytables.sourceforge.net/html-doc/

Per installation instructions I copied the 3 prereq files as noted
here:

http://pytables.sourceforge.net/html...ubsection2.2.1

I am getting an error in the following section:

http://pytables.sourceforge.net/html...ubsection3.1.1

In particular, "from tables import *" gives the following error:

Traceback (most recent call last):
File "<pyshell#0>", line 1, in -toplevel-
from tables import *
File "...\site-packages\tables\__init__.py", line 33, in
-toplevel-
from tables.hdf5Extension import\
ImportError: No module named hdf5Extension

Note that the only file with the name "hdf5Extension" in the
"...\site-packages\tables\" directory has the extension ".pyd", not
".py" or ".pyc".

Suggestions?

Thanks in advance,

-Ben

Jul 19 '05 #1
0 1114

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by John Bradbury | last post: by
5 posts views Thread by Ajith Prasad | last post: by
3 posts views Thread by Neter Smith | last post: by
1 post views Thread by py_genetic | last post: by
reply views Thread by gheharukoh7 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.