469,603 Members | 2,110 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,603 developers. It's quick & easy.

AM_PATH_PYTHON - version problem

Hi,

I use the GNU autotools for packaging my python applications. My problem is
that as I have both python2.3 and python2.4 installed the automake macros
always detects the newest version and sets it path variables accordingly.

How can I package the program for different versions of Python?
(i.e. for generating binary packages)

Any ideas?

Thanks,
Ciao
Uwe
Jul 19 '05 #1
1 1567
Uwe Mayer wrote:
Hi,

I use the GNU autotools for packaging my python applications. My problem is
that as I have both python2.3 and python2.4 installed the automake macros
always detects the newest version and sets it path variables accordingly.

How can I package the program for different versions of Python?
(i.e. for generating binary packages)

Any ideas?

Thanks,
Ciao
Uwe

wxPython provides a method for linking to different Python versions.

Robin Dunn's approach might help.

Colin W.
Jul 19 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

By using this site, you agree to our Privacy Policy and Terms of Use.