470,594 Members | 1,412 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,594 developers. It's quick & easy.

ClientForm question

Hi,
I need some help on using ClientForm to post to cgi and getting
response. I have done this many times and it worked very well until
now. I have contacted the webmaster of the page I'm interested in an
this is the response I got:
Indeed, a simple wget does _not_ do the trick for
our servers.
You must start by doing a POST (e.g. not a GET) with
the
form data. From what i can guess about the python
code it
seems to be doing the post correctly.

The response page to that form is a very short page
that
reloads another page (using javascript). This page
will eventually
contain the resulting webpage. You should try
reloading it until
it no longer tells you that your job is queued or
processing.
Use a nice poll timeout, say 10 every seconds. If
the job
takes a long time (or the queue is full) the page
will take
a few seconds to load. This is intentional, as the
cgi-script in this period automatically polls the
status of
the job, and issues a javascript re-load if it
finishes
within the time of the page-load (now showing the
result).

Hope this helps....


The post I do returnes and error from the python code saying there is
no form field called xxx but actually it exists in the form.

Any help is appreciated, thanks for your time...

Jul 19 '05 #1
0 997

This discussion thread is closed

Replies have been disabled for this discussion.

By using this site, you agree to our Privacy Policy and Terms of Use.