By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
454,525 Members | 1,689 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 454,525 IT Pros & Developers. It's quick & easy.

py2exe + XML-RPC problem

P: n/a
I tried to take the Monkey Shell script
( and
make it into an executable. I am making an executable for the server
piece ( So my looks like this

from distutils.core import setup
import py2exe
import sys
import xmlrpclib
import os
import string
from SimpleXMLRPCServer import *
from ConfigParser import *
setup(console=[{"script": ''}],

....which i think is right. I imported the same imports as uses (is that necessary??) And i execute it like...

python py2exe

Anyhow, i run the setup and get a monkey_shelld.exe. I can run the exe
and the server runs just fine. Then I connect to the server using the
client (, and when I execute a command, the client
side prints out an error...

xmlrpclib.ProtocolError: <ProtocolError for 500
Internal error

now, when i run the server script (i.e. python,
everything works fine (i.e. i can send commands from client and get
server response), but when I try to use the server executable
(monkey_shelld.exe) I get the error (shown above) when I try to execute
a command.

Any ideas? I am guessing that I am missing something from my

Info that may be helpful in answering:
OS: win xp
Python ver: 2.4.1
py2exe ver: 0.5.4


Jul 19 '05 #1
Share this Question
Share on Google+
2 Replies

P: n/a
update to this. I generated an exe for the client and server. They
both run fine, except, when i send a command from the client to server,
the cleint spits out this..

xmlrpclib.ProtocolError: <ProtocolError for -1 >

When I run the .py's by themselves I do not get this. This only occurs
with the generated .exe's.


Jul 19 '05 #2

P: n/a
sorry, I am actually still getting the 500 internal error I reported

thanks for ur input.

Jul 19 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.