By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,587 Members | 1,734 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,587 IT Pros & Developers. It's quick & easy.

can't link Python 2.4.1 against external libxml2 ...

P: n/a
hi all,

i've successfully built Python-2.4.1 from src on OSX 10.3.8 as a framework
install with:

./configure \
--enable-framework \
--with-threads \
--with-cxx=g++ \
--enable-ipv6 \
--enable-toolbox-glue

make frameworkinstall

i'm next attempting to build same but linking against an external instance of
libxml2 (v2.6.18) installed in /usr/local ...

i've tried the ususal combinations of setting LDFLAGS and/or assigning
--with-libs (="/usr/local/lib/libxml2.2.6.18.dylib"), to no avail.

no matter what i do, the build links against the 'native' /usr/lib/libxml* ...
successful w/ no error, just the 'wrong' lib.

wondering whether i had unusual path probs, i also tried mv'ing the native libs
out of the way, so that the only instance of libxml* is found in
/usr/local/lib, but then the make fails, complaining that /usr/lib/libxml* is
not found. sigh.

i'm fairly sure i'm missing something trivial here ...

any suggestions/pointers as to how to link *my* libxml into the framework build?

thanks!

richard

Jul 18 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.