By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,629 Members | 1,222 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,629 IT Pros & Developers. It's quick & easy.

distutils setup ignoring scripts

P: n/a
I'm using Python 2.2 on RH9. I have a set of Python modules organized
into a root package and one other package named foobar. setup.py looks
like this:

from distutils.core import setup

setup(
name = 'foobar',
version = '0.3',
description = 'Foo Bar',
author = 'Jack Orenstein',
author_email = 'j**@geophile.com',
packages = ['', 'xyz'],
scripts = ['bin/foobar']
)

The resulting package has everything in the specified directories, but
does not include the script. I've tried making the path bin/foobar
absolute, but that doesn't help. I've googled for known bugs of this
sort but have come up emtpy. (The first line of bin/foobar is
#!/usr/bin/python.)

I've also tried using DISTUTIL_DEBUG, which has been uninformative,
(e.g. no mention of bin/foobar at all).

Can anyone see what I'm doing wrong?

Jack Orenstein

Jul 18 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.