By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,345 Members | 1,783 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,345 IT Pros & Developers. It's quick & easy.

distutils linux script installation broken?

P: n/a
Hi all,
I have been successfully deploying my own python package with distutils
for some time now, but lately, with Python 2.4, the build_scripts
command has been behaving badly. In the part where it is supposed to
adjust the first line of the script it now produces

#!None

instead of

#!/whereverpythonis/python

Has anyone else encountered this?

Cheers,
Cory.

Jul 18 '05 #1
Share this Question
Share on Google+
7 Replies


P: n/a
On Wed, 12 Jan 2005 10:09:03 +0000, Cory Davis <cd********@NOSPstaffmail.ed.ac.uk> wrote:
command has been behaving badly. In the part where it is supposed to
adjust the first line of the script it now produces

#!None

instead of

#!/whereverpythonis/python

Has anyone else encountered this?


I haven't (as I am not using 2.4 :-) )

However, there is an easy way around this, just use

#!/usr/bin env python

instead.
Albert
--
Unlike popular belief, the .doc format is not an open publically available format.
Jul 18 '05 #2

P: n/a
Thanks Albert.
I already do use #!/usr/bin/env python in my package directory, but the
build_scripts part of "setup.py install" changes this line to #!None
before copying to my bin directory.

Cheers,
Cory.

Albert Hofkamp wrote:
On Wed, 12 Jan 2005 10:09:03 +0000, Cory Davis <cd********@NOSPstaffmail.ed.ac.uk> wrote:
command has been behaving badly. In the part where it is supposed to
adjust the first line of the script it now produces

#!None

instead of

#!/whereverpythonis/python

Has anyone else encountered this?

I haven't (as I am not using 2.4 :-) )

However, there is an easy way around this, just use

#!/usr/bin env python

instead.
Albert


Jul 18 '05 #3

P: n/a
I just installed python2.4 and used it to install a set of scripts I
had previously been using distutils with. It worked fine, and replaced
the first line with:

#!/usr/local/bin/python2.4

distutils should replace that first line with the location of the
binary used to run setup.py. Are you running setup with the following
command line?

python setup.py install

Jul 18 '05 #4

P: n/a
Hi Christopher
distutils should replace that first line with the location of the
binary used to run setup.py. Are you running setup with the following
command line?

python setup.py install


Yes.

A possible complication is that I also have python 2.3.? on that
machine, which I am reluctant to remove incase it disturbs my linux
distribution (Fedora Core 2).
Its also possible that I have done something silly to an environment
variable. To check this I will try installing my package either as root
or another user.

Cheers,
Cory.

Jul 18 '05 #5

P: n/a
I've got python 2.3.3, 2.4, and 1.5.2 (which came preinstalled) on my
linux box. It's redhat 7.2 (I know... I would upgrade, but it would
void my service contract, so I just install things in /usr/local). You
can check if PYTHONHOME or PYTHONPATH are set, which may somehow be
interfering. I don't have those variables set. If they are set, you
could try running:

python -E setup.py install

The -E option should make python ignore those environment variables.
Good luck, I hope this helps.

Chris

Jul 18 '05 #6

P: n/a
Thanks for the help Chris. I tried the -E option, and also installing as
root with no change - the scripts in the bin directory still end up with
#!None on the first line. Next step is to reinstall Python 2.4, and if
that doesn't work I'll just stick with 2.3.4.

Cheers,
Cory.

Christopher De Vries wrote:
I've got python 2.3.3, 2.4, and 1.5.2 (which came preinstalled) on my
linux box. It's redhat 7.2 (I know... I would upgrade, but it would
void my service contract, so I just install things in /usr/local). You
can check if PYTHONHOME or PYTHONPATH are set, which may somehow be
interfering. I don't have those variables set. If they are set, you
could try running:

python -E setup.py install

The -E option should make python ignore those environment variables.
Good luck, I hope this helps.

Chris


Jul 18 '05 #7

P: n/a
Problem solved. I was actually using scipy_distutils and not distutils,
without good reason. Changing setup.py to use distutils made the
problem go away.

Cory.

Cory Davis wrote:
Hi all,
I have been successfully deploying my own python package with distutils
for some time now, but lately, with Python 2.4, the build_scripts
command has been behaving badly. In the part where it is supposed to
adjust the first line of the script it now produces

#!None

instead of

#!/whereverpythonis/python

Has anyone else encountered this?

Cheers,
Cory.


Jul 18 '05 #8

This discussion thread is closed

Replies have been disabled for this discussion.