By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
439,985 Members | 1,575 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 439,985 IT Pros & Developers. It's quick & easy.

Documenting data members

P: n/a

Hello,

I have a custom module which among others contains a dictionary, acting as a
"constant". I want to document it, but no matter what I do, it doesn't show
up in `pydoc`. For example, the following doesn't work:

"""
A dictionary of the namespaces.
"""
xmlns = {
....
}

or

xmlns = {
"""
A dictionary of the namespaces.
"""
....
}

Bottom line: how do I document data members?

I also have another documentation question:

In a module which I install, the file starts with a comment containing a
license header, to then be followed by a Python documentation string("""this
module ..."""). The problem is that in pydoc, I get the uninteresting license
header as documentation, instead of the doc string. I want to have the
license header at the top.
Is this somehow fixable? That the doc string, instead of the license header,
shows up in pydoc despite the latter being first in the file?
Cheers,

Frans
Jul 18 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
In <ma**************************************@python.o rg>, Frans Englich
wrote:
I have a custom module which among others contains a dictionary, acting as a
"constant". I want to document it, but no matter what I do, it doesn't show
up in `pydoc`. For example, the following doesn't work:
I'm using epydoc_ for my documentation and there the module level and
class level variables are documented in the module/class docstring with
special markup.
"""
A dictionary of the namespaces.
"""
xmlns = {
...
}


Will become:

""" (Module description)

:var xmlns: A dictionary of the namespaces.
"""

Ciao,
Marc 'BlackJack' Rintsch

... _epydoc: http://epydoc.sourceforge.net/
Jul 18 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.