By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,299 Members | 1,228 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,299 IT Pros & Developers. It's quick & easy.

effbot TidyHTMLTreeBuilder problem

P: n/a
Hi all,

I'm using TidyHTMLTreeBuilder to model syntax structure of HTML
documents. I've been trying to feed in Yahoo and CNN, but the parser
seems to crash:

" File
"C:\Python23\Lib\site-packages\elementtidy\TidyHTMLTreeBuilder.py",
line 89, in parse
return ElementTree.parse(source, TreeBuilder())
File "C:\Python23\lib\site-packages\elementtree\ElementTree.py", line
865, in parse
tree.parse(source, parser)
File "C:\Python23\lib\site-packages\elementtree\ElementTree.py", line
590, in parse
self._root = parser.close()
File
"C:\Python23\Lib\site-packages\elementtidy\TidyHTMLTreeBuilder.py",
line 75, in close
return ElementTree.XML(stdout)
File "C:\Python23\lib\site-packages\elementtree\ElementTree.py", line
879, in XML
return parser.close()
File "C:\Python23\lib\site-packages\elementtree\ElementTree.py", line
1169, in close
self._parser.Parse("", 1) # end of data
ExpatError: no element found: line 1, column 0"

Could someone else please try it on their system and see if they also
have the same problem? I suspect this problem relates to <form> inside
<table>.

Thank you very much for any help.

Cheers,
Michael

Jul 18 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.