473,246 Members | 1,509 Online
Bytes | Software Development & Data Engineering Community
Post Job

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 473,246 software developers and data experts.

problem installing MySQLdb on Solaris 8

I'm trying to install MySQLdb 0.9.2 so I can access my MySQL database from
python under Solaris 8. I found the notes on changing the include and lib
paths and it seems to find them okay, but when I run 'python setup.py
build', I get these errors:

....
building '_mysql' extension
creating build/temp.solaris-2.8-sun4u-2.3
gcc -fno-strict-aliasing -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -fPIC -I/
usr/include/mysql -I/usr/local/include/mysql -I/usr/local/mysql/include/ -I/
usr/local/include/python2.3 -c _mysql.c -o
build/temp.solaris-2.8-sun4u-2.3/_mysql.o -fPIC
_mysql.c: In function `_mysql_ConnectionObject_info':
_mysql.c:1150: warning: assignment discards qualifiers from pointer target
type
_mysql.c: In function `_mysql_ConnectionObject_stat':
_mysql.c:1379: warning: assignment discards qualifiers from pointer target
type
_mysql.c: At top level:
_mysql.c:2007: warning: initialization from incompatible pointer type
_mysql.c:2096: warning: initialization from incompatible pointer type
gcc -shared
build/temp.solaris-2.8-sun4u-2.3/_mysql.o -L/usr/lib/mysql -L/usr/local/lib/
mysql -L/usr/local/mysql/lib/ -Wl,-R/usr/local/lib:/usr/openwin/lib:/usr/dt/
lib -lmysqlclient_r -lz -o build/lib.solaris-2.8-sun4u-2.3/_mysql.so
ld: warning: file /usr/local/lib/mysql/libmysqlclient_r.a(libmysql.o): wrong
ELF class: ELFCLASS64

My configuration is:
bash-2.05$ python
Python 2.3.3 (#1, Feb 11 2004, 14:47:54)
[GCC 3.3.2] on sunos5
Type "help", "copyright", "credits" or "license" for more information.
import zlib
zlib.__version__ '1.0' ^D

bash-2.05$

The server is a Sun Netra T1, which has a 64-bit SPARC in it.

I tried adding '-m64' to the extra_link_args in setup.py, then I removed the
'build' directory and built again, but then I got:
....
ld: fatal: file build/temp.solaris-2.8-sun4u-2.3/_mysql.o: wrong ELF class:
ELFCLASS32
ld: fatal: File processing errors. No output written to
build/lib.solaris-2.8-sun4u-2.3/_mysql.so

What do I need to do to get MySQLdb installed on Solaris 8?
Thanks,
Bob
Jul 18 '05 #1
0 1963

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

4
by: Perflubron | last post by:
Hi, I'm having trouble installing MySQLdb 0.9.2 on the following Cygwin system: - Python 2.2.2 - MySQL 3.23.57 - gcc 2.95.3-10 The steps I take are: 1. Modify setup.py - Set...
0
by: matt okeson-harlow | last post by:
i am getting errors trying to build MySQLdb on solaris 8, i have tried changing the libs, no joy, anyone have any ideas? Python 2.3.4 gcc -v Reading specs from...
2
by: ws Wang | last post by:
MySQLdb is working fine at command line, however when I tried to use it with mod_python, it give me a "server not initialized" error. This is working fine: ----------------------- testmy.py...
2
by: P.L. | last post by:
Hi all, I am trying to install DB2 Universal Database Enterprise Server Edition v8.1 (db81eeso.zip) on a Blade2000 running Solaris 2.8 (with latest Recommended patches installed) with 512M RAM...
8
by: ReeseDog | last post by:
I have a AIX backup of DB2 (8.2) and i was told i needed to have a unix OS installed to be able to restore this database. So now i have installed Solaris 10 (x86 hardware). I copied the DB2.tar...
1
by: gmax2006 | last post by:
Hi, I am having hard time with installing MySQLdb on Linux. My Python version is 2.3. I have downloaded "MySQL-python-1.2.1_p2.tar.gz" from sourceforge. The README file asks for MySQL...
4
by: goodepic | last post by:
I'm newish to python and just got my first mac, so sorry if this is stupid. I have a little app developed by someone else in wxGlade that implements a complex stats package and language package,...
2
by: Sean O'Donnell | last post by:
Hi, I can't seem to get MySQLdb/1.2.1p2 to install on Slackware/10.2, with Python/2.4.1, and MySQL/5.0.18. The following command: $ python setup.py build 2setup.err returns the following...
8
by: geert | last post by:
Hi all, I have a mac mini running maocosx 10.5 leopard I want to deploy a django project on. My backend is MySQL, and I have it running as a 64- bit app. Of course, apache2 is also running as...
0
by: stefan129 | last post by:
Hey forum members, I'm exploring options for SSL certificates for multiple domains. Has anyone had experience with multi-domain SSL certificates? Any recommendations on reliable providers or specific...
1
by: davi5007 | last post by:
Hi, Basically, I am trying to automate a field named TraceabilityNo into a web page from an access form. I've got the serial held in the variable strSearchString. How can I get this into the...
0
by: MeoLessi9 | last post by:
I have VirtualBox installed on Windows 11 and now I would like to install Kali on a virtual machine. However, on the official website, I see two options: "Installer images" and "Virtual machines"....
0
by: DolphinDB | last post by:
Tired of spending countless mintues downsampling your data? Look no further! In this article, you’ll learn how to efficiently downsample 6.48 billion high-frequency records to 61 million...
0
by: Aftab Ahmad | last post by:
Hello Experts! I have written a code in MS Access for a cmd called "WhatsApp Message" to open WhatsApp using that very code but the problem is that it gives a popup message everytime I clicked on...
0
by: Aftab Ahmad | last post by:
So, I have written a code for a cmd called "Send WhatsApp Message" to open and send WhatsApp messaage. The code is given below. Dim IE As Object Set IE =...
0
by: ryjfgjl | last post by:
ExcelToDatabase: batch import excel into database automatically...
0
by: marcoviolo | last post by:
Dear all, I would like to implement on my worksheet an vlookup dynamic , that consider a change of pivot excel via win32com, from an external excel (without open it) and save the new file into a...
0
isladogs
by: isladogs | last post by:
The next Access Europe meeting will be on Wednesday 6 Mar 2024 starting at 18:00 UK time (6PM UTC) and finishing at about 19:15 (7.15PM). In this month's session, we are pleased to welcome back...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.