By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
444,089 Members | 2,359 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 444,089 IT Pros & Developers. It's quick & easy.

decompyle with Python 2.3 support

P: n/a
Hi.

I've added Python 2.3 support to decompyle. All I did was to
add the new header ID of .pyc files and to remove some obsolete
op-codes (which are not present in opcode.py).

There are files which it can't decompile but it usually works.

If you're interested you can download it here:
http://adal.eu.org/decompyle.php

Regards,
Adal Chiriliuc

Jul 18 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Adal Chiriliuc wrote:
Hi.

I've added Python 2.3 support to decompyle. All I did was to
add the new header ID of .pyc files and to remove some obsolete
op-codes (which are not present in opcode.py).

There are files which it can't decompile but it usually works.

If you're interested you can download it here:
http://adal.eu.org/decompyle.php

Regards,
Adal Chiriliuc


You're a hero!
I was wishing someone would do this. Hopefully this will convince
crazy-compilers to start releasing their source again...

David
Jul 18 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.