By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,766 Members | 1,432 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,766 IT Pros & Developers. It's quick & easy.

ZMySQLDA/MySQLdb: DON'T fix like this for Zope 2.7.0!

P: n/a
Michal Kurowski wrote:
transactional = self.db.server_capabilities & CLIENT.TRANSACTIONS

to:

transactional = CLIENT.TRANSACTIONS
This is NOT a good fix. All you're doing is ignoring the server's capabilities,
so if the server supports transactions and the client doesn't, or vice versa,
you end up in a mess.

I have a patch which I'm testing and will post soon.
db.py file from ZmySQLDA is requirement for python 2.3.3 based
zope to work.
I think the idea is that you're supposed to use mysql-python 0.9.3b2 with Python
2.3, but there's no Windows binary for that.
Can anyone explain to me why "_mysql" (instead of "MySQLdb") is used
here in the first place ?

Andy Dustman recommends against it for years now.


Well, ZMySQLDA is Andy's code, so perhaps he could comment? ;-)

Chris

--
Simplistix - Content Management, Zope & Python Consulting
- http://www.simplistix.co.uk
Jul 18 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.