By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
448,483 Members | 1,045 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 448,483 IT Pros & Developers. It's quick & easy.

Installing Python 2.3.3 on RH 7.3

P: n/a
Hi,

I have a strange problem. I want to install Plone
(Plone2-2.0.0rh-2.i386.rpm) Because Plone 2.0 needs Python 2.3.3, I
installed Python 2.3.3 from source (Python-2.3.3.tar).

Everything went well. After installing Python I did a reboot of the server
and checked if Python works.

Quote:
[root@homeserver root]# python
Python 2.3.3 (#1, Mar 28 2004, 11:29:35)
[GCC 2.96 20000731 (Red Hat Linux 7.3 2.96-113)] on linux2
Type "help", "copyright", "credits" or "license" for more information.

So I suppose I installed the right version of Python. But when I tried to
install Plone2-2.0.0rh-2.i386.rpm it gives the following error:

Quote:
[root@homeserver Zope-Plone]# rpm -Uvh Plone2-2.0.0rh-2.i386.rpm
error: failed dependencies:
/usr/bin/python2.3 is needed by Plone2-2.0.0rh-2
expat >= 1.95.5 is needed by Plone2-2.0.0rh-2
libc.so.6(GLIBC_2.3) is needed by Plone2-2.0.0rh-2
python2.3 >= 2.3.3 is needed by Plone2-2.0.0rh-2
When I installed Python from source, Python was installed in
"/usr/local/bin/" in stead of "/usr/bin/" so I copied "Python2.3" from
"/usr/local/bin/" to "/usr/bin/" but that doesn't help.

What can I do to change (or extend) the path so Plone can find the right
version of Python.

Thanks,

Rien
Jul 18 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
"Rien Kok" <ri**@focus.demon.nl> wrote in message news:<10*************@corp.supernews.com>...
Hi,

I have a strange problem. I want to install Plone
(Plone2-2.0.0rh-2.i386.rpm) Because Plone 2.0 needs Python 2.3.3, I
installed Python 2.3.3 from source (Python-2.3.3.tar).

Everything went well. After installing Python I did a reboot of the server
and checked if Python works.

Quote:
[root@homeserver root]# python
Python 2.3.3 (#1, Mar 28 2004, 11:29:35)
[GCC 2.96 20000731 (Red Hat Linux 7.3 2.96-113)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>>

So I suppose I installed the right version of Python. But when I tried to
install Plone2-2.0.0rh-2.i386.rpm it gives the following error:

Quote:
[root@homeserver Zope-Plone]# rpm -Uvh Plone2-2.0.0rh-2.i386.rpm
error: failed dependencies:
/usr/bin/python2.3 is needed by Plone2-2.0.0rh-2
expat >= 1.95.5 is needed by Plone2-2.0.0rh-2
libc.so.6(GLIBC_2.3) is needed by Plone2-2.0.0rh-2
python2.3 >= 2.3.3 is needed by Plone2-2.0.0rh-2
When I installed Python from source, Python was installed in
"/usr/local/bin/" in stead of "/usr/bin/" so I copied "Python2.3" from
"/usr/local/bin/" to "/usr/bin/" but that doesn't help.

What can I do to change (or extend) the path so Plone can find the right
version of Python.

Thanks,

Rien


Rien,

I have the same problem with install Plone 2 on Redhat 9.0. Did you
find an answer to the problem?

Carl
Jul 18 '05 #2

P: n/a


Carl L wrote:
"Rien Kok" <ri**@focus.demon.nl> wrote in message news:<10*************@corp.supernews.com>...
Hi,

I have a strange problem. I want to install Plone
(Plone2-2.0.0rh-2.i386.rpm) Because Plone 2.0 needs Python 2.3.3, I
installed Python 2.3.3 from source (Python-2.3.3.tar).

I have the same problem with install Plone 2 on Redhat 9.0. Did you
find an answer to the problem?


Source installations are not supported by rpms. I managed to put a howto
together now to get around these confusions :)

See http://longsleep.org/howto/rh9-python233
and http://plone.org/downloads/rpm-notes

cheers,
Simon
Jul 18 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.