By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,621 Members | 1,104 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,621 IT Pros & Developers. It's quick & easy.

Installing RPM rebuild and failed dependency

P: n/a
I'm running Redhat9 and I want to install Python2.3. I downloaded
the src RPM file and following the directions
(i.e. rpmbuild --rebuild python2.3-2.3.3-2pydotorg.src.rpm).

This runs configure, compiled and dumps all the rpms in my
main RPM directory. I've got BerkeleyDB installed in
/usr/local/BerkeleyDB.4.2.

When I try and install the built RPM I get the following error:
error: Failed dependencies:
libdb-4.2.so is needed by python2.3-2.3.3-2pydotorg

That file is located in /usr/local/BerkeleyDB.4.2/lib but the
RPM install apparently cant find it. I tried creating a
symbolic link in /usr/lib to the libdb-4.2.so file and
I still get the same error.

Any ideas?

Thanks,

- Brent
Jul 18 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Brent L Johnson wrote:

Any ideas?


install the source rpm, edit the spec file and make sure python is built
against the local db4 library and knows where it is.

Why can't you use the db4 packages included in RH9?
c

Jul 18 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.