By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,760 Members | 969 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,760 IT Pros & Developers. It's quick & easy.

Restoring my own PyGNOME panel applets under GNOME 1.4

P: n/a
I'm playing around with writing my own panel applets, and I'm trying
to figure out how to get my panel applets to be restored when I log
in. As an experiment, I'm using the simple clock applet that comes
with PyGNOME (clock-applet.py). It works fine when I run it from the
shell, but when I log out and log in again, there's just a tiny
GNOME-foot icon where the applet should be.

After poking around in ~/.gnome/panel.d, I think I've figured out that
the panel knows there should be an applet in that spot, but there's
nothing telling it what executable to run to put the applet there. Do
I somehow need to create that mapping, or is the problem something
else altogether?

Applets I add to the panel through the normal process (right-click ->
Applets -> ...) are restored when I log in, as expected.

I'm using GNOME 1.4 on Red Hat 7.3 (sorry, but this is a work system,
and I can't upgrade; I also can't put my code where the system applets
are). Thanks for any help you can offer.
Jul 18 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
vm*********@yahoo.com (Vincent Montressor) wrote in message news:<88**************************@posting.google. com>...
I'm playing around with writing my own panel applets, and I'm trying
to figure out how to get my panel applets to be restored when I log
in. As an experiment, I'm using the simple clock applet that comes
with PyGNOME (clock-applet.py). It works fine when I run it from the
shell, but when I log out and log in again, there's just a tiny
GNOME-foot icon where the applet should be.


Ah, never mind: adding the applet to my GNOME startup programs list solved it. Duh.
Jul 18 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.